summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-10-15 15:16:56 -0500
committerPatrick Williams <patrick@stwcx.xyz>2015-10-15 15:16:56 -0500
commit96247db50c8969fa3d4bae00c272827ed876ff20 (patch)
tree3fb24953fb0dea65c885a4a2ff853d691a8c4cbd /meta-phosphor
parentca82111bb69663eda622ceaaa1515bc99fd63b82 (diff)
parent2ac6f93a6e419a47e1fad83eba038fff75951646 (diff)
downloadtalos-openbmc-96247db50c8969fa3d4bae00c272827ed876ff20.tar.gz
talos-openbmc-96247db50c8969fa3d4bae00c272827ed876ff20.zip
Merge pull request #14 from vishwabmc/master
bitbake and package files for host-ipmid
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/files/host-ipmid.service8
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb20
-rw-r--r--meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-apps.bb1
3 files changed, 29 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/files/host-ipmid.service b/meta-phosphor/common/recipes-phosphor/host-ipmid/files/host-ipmid.service
new file mode 100644
index 000000000..0636f12d2
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/files/host-ipmid.service
@@ -0,0 +1,8 @@
+[Unit]
+Description="Phosphor OpenBMC IPMI daemon"
+
+[Service]
+ExecStart=/usr/sbin/ipmid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
new file mode 100644
index 000000000..9741e61b5
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor OpenBMC IPMI daemon"
+DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
+HOMEPAGE = "http://github.com/openbmc/phosphor-host-ipmid"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+DEPENDS += "glib-2.0"
+SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid"
+
+SRCREV = "02d37aab090090af9a779f4039931a6721bff615"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -m 0755 -d ${D}${sbindir} ${D}${libdir} ${D}${libdir}/host-ipmid/
+ install -m 0755 ${S}/ipmid ${D}${sbindir}/
+ install -m 0755 ${S}/libapphandler.so ${D}${libdir}/host-ipmid/
+}
diff --git a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-apps.bb b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-apps.bb
index 8aa6ba8ca..4dbcdd37e 100644
--- a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-apps.bb
+++ b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-apps.bb
@@ -25,6 +25,7 @@ PACKAGES = " \
SUMMARY_packagegroup-obmc-phosphor-apps-extras = "Extra features"
RDEPENDS_packagegroup-obmc-phosphor-apps-extras = " \
rest-dbus \
+ host-ipmid \
"
SUMMARY_packagegroup-obmc-phosphor-apps-fan-mgmt = "Fan management support"
OpenPOWER on IntegriCloud