summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorRick Altherr <raltherr@google.com>2016-12-08 12:21:49 -0800
committerPatrick Williams <patrick@stwcx.xyz>2016-12-19 13:35:47 +0000
commit4d9fd23f0e7e9fa5e72a805c6694471c38cf9dc6 (patch)
tree96764c0fcd1441d21663936b0030abb87d88c5d0 /meta-phosphor
parent91eef023579b8806520789b9e770c9338c0622a2 (diff)
downloadtalos-openbmc-4d9fd23f0e7e9fa5e72a805c6694471c38cf9dc6.tar.gz
talos-openbmc-4d9fd23f0e7e9fa5e72a805c6694471c38cf9dc6.zip
Create a phosphor-specific initramfs
OpenBMC has been using a .bbappend to add/remove packages from core-image-minimal-initramfs. Doing so keeps the recipe and initramfs image name as core-image-minimal-initramfs which is misleading as it now is very much phosphor-specific. Instead, make a new obmc-phosphor-initramfs recipe and image that is patterned after core-image-minimal-initramfs. Change-Id: Ieca2268eff01bb61cc0d25a1cbc1a6f5fadb6d2c Signed-off-by: Rick Altherr <raltherr@google.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/image-overlay.bbclass2
-rw-r--r--meta-phosphor/common/recipes-core/images/core-image-minimal-initramfs.bbappend4
-rw-r--r--meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb21
3 files changed, 22 insertions, 5 deletions
diff --git a/meta-phosphor/classes/image-overlay.bbclass b/meta-phosphor/classes/image-overlay.bbclass
index dbe4daf40..68acca9bc 100644
--- a/meta-phosphor/classes/image-overlay.bbclass
+++ b/meta-phosphor/classes/image-overlay.bbclass
@@ -1,7 +1,7 @@
PACKAGES = " "
EXCLUDE_FROM_WORLD = "1"
-INITRD_IMAGE ?= "core-image-minimal-initramfs"
+INITRD_IMAGE ?= "obmc-phosphor-initramfs"
INITRD ?= "${DEPLOY_DIR_IMAGE}/${INITRD_IMAGE}-${MACHINE}.cpio.${INITRD_CTYPE}${uboot}"
IMAGE_BASETYPE ?= "squashfs-xz"
diff --git a/meta-phosphor/common/recipes-core/images/core-image-minimal-initramfs.bbappend b/meta-phosphor/common/recipes-core/images/core-image-minimal-initramfs.bbappend
deleted file mode 100644
index 5710d22c4..000000000
--- a/meta-phosphor/common/recipes-core/images/core-image-minimal-initramfs.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-PACKAGE_INSTALL_remove = "initramfs-live-boot initramfs-live-install initramfs-live-install-efi"
-PACKAGE_INSTALL += "obmc-phosphor-initfs"
-INITRAMFS_CTYPE ?= "lzma"
-INITRAMFS_FSTYPES = "cpio.${INITRAMFS_CTYPE}"
diff --git a/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb
new file mode 100644
index 000000000..b68048a50
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
+first 'init' program more efficiently."
+
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "obmc-phosphor-initramfs"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
OpenPOWER on IntegriCloud