summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@us.ibm.com>2015-10-30 03:11:05 -0400
committerBrad Bishop <bradleyb@us.ibm.com>2015-10-30 03:20:01 -0400
commitfebd61ae3e64f7ef00eeb518108878bc0311f607 (patch)
tree4216a90948e083ecaeea37a46500d4a408f89184 /meta-phosphor
parentc33101df40ad24185c41503469d3fbead4f54a9a (diff)
downloadtalos-openbmc-febd61ae3e64f7ef00eeb518108878bc0311f607.tar.gz
talos-openbmc-febd61ae3e64f7ef00eeb518108878bc0311f607.zip
Use out of (kernel) tree defconfig
I finally figured out how to get kernel config fragments working. This allows removal of some earlier kernel recipe hacks. Part 1 of 2 ( meta-phosphor, meta-openbmc-bsp )
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg8
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc8
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg3
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc17
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb12
5 files changed, 2 insertions, 46 deletions
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg
deleted file mode 100644
index 17c8b503d..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg
+++ /dev/null
@@ -1,8 +0,0 @@
-#
-# Used by yocto-kernel to manage config options.
-#
-# yocto-kernel may change the contents of this file in any
-# way it sees fit, including removing comments like this,
-# so don't manually make any modifications you don't want
-# to lose.
-#
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc
deleted file mode 100644
index 7a598d911..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc
+++ /dev/null
@@ -1,8 +0,0 @@
-#
-# Used by yocto-kernel to manage patches.
-#
-# yocto-kernel may change the contents of this file in any
-# way it sees fit, including removing comments like this,
-# so don't manually make any modifications you don't want
-# to lose.
-#
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg
deleted file mode 100644
index 95170b12e..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg
+++ /dev/null
@@ -1,3 +0,0 @@
-#
-# A convenient place to add config options, nothing more.
-#
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc
deleted file mode 100644
index 88e76e649..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# The top-level 'feature' for the meta-obmc-bsp custom kernel.
-#
-# Essentially this is a convenient top-level container or starting
-# point for adding lower-level config fragements and features.
-#
-
-# meta-obmc-bsp.cfg in the linux-yocto-custom subdir is just a
-# convenient place for adding random config fragments.
-
-kconf hardware obmc-bsp.cfg
-
-# These are used by yocto-kernel to add config fragments and features.
-# Don't remove if you plan on using yocto-kernel with this BSP.
-
-kconf hardware obmc-bsp-user-config.cfg
-include obmc-bsp-user-patches.scc
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
index 81edb70c0..f49b3fcce 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
@@ -3,16 +3,12 @@ SECTION = "kernel"
LICENSE = "GPLv2"
KBRANCH ?= "dev"
+KCONFIG_MODE="--alldefconfig"
SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
-SRC_URI += "file://obmc-bsp.scc \
- file://obmc-bsp.cfg \
- file://obmc-bsp-user-config.cfg \
- file://obmc-bsp-user-patches.scc \
- "
LINUX_VERSION ?= "4.2"
-LINUX_VERSION_EXTENSION ?= "-openbmc-${SRCPV}"
+LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
SRCREV="openbmc-20151028-1"
@@ -22,7 +18,3 @@ COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
-
-do_configure_prepend() {
- sed -i 's/CONFIG_LOCALVERSION=.\+/CONFIG_LOCALVERSION=${LINUX_VERSION_EXTENSION}/' ${S}/arch/${ARCH}/configs/${KMACHINE}_defconfig
-}
OpenPOWER on IntegriCloud