summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@us.ibm.com>2015-10-18 22:21:04 -0400
committerBrad Bishop <bradleyb@us.ibm.com>2015-10-18 22:21:04 -0400
commit09494ec728d325e14606c8168269dd1fc5e590f1 (patch)
tree38e7c7d009a552926b5cc103f92452b7bc328d59 /meta-phosphor
parent51607d2c0383ff341bcd348b015d3fa8fb76c3f0 (diff)
downloadtalos-openbmc-09494ec728d325e14606c8168269dd1fc5e590f1.tar.gz
talos-openbmc-09494ec728d325e14606c8168269dd1fc5e590f1.zip
Remove S and SRC_URI from c daemon class
Initially this could be done in one place but as sources move to git repositories this can't be done in a generic manner. Adapted existing recipes to this class change.
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/obmc-phosphor-c-daemon.bbclass10
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/obmc-phosphor-fand.bb5
3 files changed, 13 insertions, 6 deletions
diff --git a/meta-phosphor/classes/obmc-phosphor-c-daemon.bbclass b/meta-phosphor/classes/obmc-phosphor-c-daemon.bbclass
index e21d17c05..0ceed960e 100644
--- a/meta-phosphor/classes/obmc-phosphor-c-daemon.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-c-daemon.bbclass
@@ -4,14 +4,12 @@ inherit obmc-phosphor-systemd
inherit obmc-phosphor-license
DEPENDS += "glib-2.0"
-SRC_URI += " \
- file://Makefile \
- file://${PN}.c \
- "
-S = "${WORKDIR}"
+
+INSTALL_NAME ?= "${PN}"
+BIN_NAME ?= "${INSTALL_NAME}"
do_install_append() {
# install the binary
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/${PN} ${D}${sbindir}
+ install -m 0755 ${S}/${BIN_NAME} ${D}${sbindir}/${INSTALL_NAME}
}
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
index 89fbdb1be..f1a9eb962 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
@@ -7,5 +7,9 @@ DBUS_SERVICES = " \
org.openbmc.examples.SDBusService1 \
"
+S = "${WORKDIR}"
+SRC_URI += "file://Makefile \
+ file://obmc-phosphor-example-sdbus.c \
+ "
inherit obmc-phosphor-sdbus-service
inherit obmc-phosphor-c-daemon
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/obmc-phosphor-fand.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/obmc-phosphor-fand.bb
index 79e2e6c88..8c937c6ed 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/obmc-phosphor-fand.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/obmc-phosphor-fand.bb
@@ -5,3 +5,8 @@ PR = "r1"
inherit obmc-phosphor-fan-mgmt
inherit obmc-phosphor-sdbus-service
inherit obmc-phosphor-c-daemon
+
+S = "${WORKDIR}"
+SRC_URI += "file://Makefile \
+ file://obmc-phosphor-fand.c \
+ "
OpenPOWER on IntegriCloud