summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2018-10-04 15:43:54 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-05 22:12:11 -0400
commitc628533c2a2a68a78c46a0d861fd5772569b65e2 (patch)
treeaa205c6b68275173ddd3fcb2e8d7b5b81925bd3a /meta-phosphor/recipes-support
parent4f79273d6aff3754f35c7a7dfec5d1e311b38fb6 (diff)
downloadtalos-openbmc-c628533c2a2a68a78c46a0d861fd5772569b65e2.tar.gz
talos-openbmc-c628533c2a2a68a78c46a0d861fd5772569b65e2.zip
meta-phosphor: Update nlohmann-json
Update to latest release and fixup recipe to use cmake. Copy styling from rapidjson in meta-oe as these have basically the same purpose. Tested-by: Verified image still built (From meta-phosphor rev: 9a6e2eebe418cfb5608f477caa327864e4037fdc) Change-Id: Iceb244a43e7a24dbdd5e2f9d4c5470796cb85d0b Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb23
1 files changed, 14 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb b/meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb
index bbb63a1bf..a89b659ae 100644
--- a/meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb
+++ b/meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb
@@ -1,18 +1,23 @@
-DESCRIPTION = "JSON for modern C++"
+SUMMARY = "JSON for modern C++"
HOMEPAGE = "https://nlohmann.github.io/json/"
+SECTION = "libs"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
SRC_URI = "git://github.com/nlohmann/json.git"
-ALLOW_EMPTY_${PN} = "1"
+PV = "3.2.0+git${SRCPV}"
-PV = "3.1.2+git${SRCPV}"
-
-SRCREV = "183390c10b8ba4aa33934ae593f82f352befefc8"
+SRCREV = "8c20571136f2d5351b379a06ad6591bd980880fe"
S = "${WORKDIR}/git"
-do_install_append(){
- install -d ${D}${includedir}/nlohmann
- install -m 644 ${S}/single_include/nlohmann/json.hpp ${D}${includedir}/nlohmann/json.hpp
-}
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
+
+# nlohmann-json is a header only C++ library, so the main package will be empty.
+
+RDEPENDS_${PN}-dev = ""
+
+BBCLASSEXTEND = "native nativesdk"
OpenPOWER on IntegriCloud