summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/video
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:25:51 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 07:44:12 -0400
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/video
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadtalos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.gz
talos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.zip
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/video')
-rw-r--r--meta-phosphor/recipes-phosphor/video/fbterm/fb.modes7
-rw-r--r--meta-phosphor/recipes-phosphor/video/fbterm/fbterm1
-rw-r--r--meta-phosphor/recipes-phosphor/video/fbterm/fbterm.service8
-rw-r--r--meta-phosphor/recipes-phosphor/video/fbterm_git.bb29
-rw-r--r--meta-phosphor/recipes-phosphor/video/liberation-fonts_2.00.1.bbappend9
-rw-r--r--meta-phosphor/recipes-phosphor/video/uart-render-controller/uart-render-controller.service14
-rw-r--r--meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb30
7 files changed, 98 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/video/fbterm/fb.modes b/meta-phosphor/recipes-phosphor/video/fbterm/fb.modes
new file mode 100644
index 000000000..dfc51fe97
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/video/fbterm/fb.modes
@@ -0,0 +1,7 @@
+mode "800x600-60"
+ # D: 40.00 MHz, H: 37.879 kHz, V: 60.32 Hz
+ geometry 800 600 800 600 32
+ timings 0 88 40 23 1 128 4
+ hsync high
+ vsync high
+endmode
diff --git a/meta-phosphor/recipes-phosphor/video/fbterm/fbterm b/meta-phosphor/recipes-phosphor/video/fbterm/fbterm
new file mode 100644
index 000000000..0cf29d433
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/video/fbterm/fbterm
@@ -0,0 +1 @@
+FB_MODE=800x600-60
diff --git a/meta-phosphor/recipes-phosphor/video/fbterm/fbterm.service b/meta-phosphor/recipes-phosphor/video/fbterm/fbterm.service
new file mode 100644
index 000000000..2b18c91ef
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/video/fbterm/fbterm.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=UART renderer
+Requires=obmc-console@ttyVUART0.service
+
+[Service]
+EnvironmentFile={envfiledir}/fbterm
+ExecStartPre=/usr/sbin/fbset $FB_MODE
+ExecStart=/usr/bin/fbterm --write-only obmc-console-client
diff --git a/meta-phosphor/recipes-phosphor/video/fbterm_git.bb b/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
new file mode 100644
index 000000000..0c171dd3a
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
@@ -0,0 +1,29 @@
+HOMEPAGE = "https://github.com/jk-ozlabs/fbterm"
+LICENSE = "GPLv2+"
+
+SRC_URI += "git://github.com/jk-ozlabs/fbterm.git;nobranch=1"
+SRC_URI += "file://fb.modes"
+PR = "r1"
+
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=d8e20eece214df8ef953ed5857862150"
+
+DEPENDS += "freetype"
+DEPENDS += "fontconfig"
+
+inherit autotools
+inherit pkgconfig
+inherit obmc-phosphor-systemd
+
+SRCREV = "c15430560aeb82a27358cc320af4a29e1296e6c1"
+PV = "1.7+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install-exec
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}/
+}
+
+SYSTEMD_SERVICE_${PN} += "fbterm.service"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "fbterm"
diff --git a/meta-phosphor/recipes-phosphor/video/liberation-fonts_2.00.1.bbappend b/meta-phosphor/recipes-phosphor/video/liberation-fonts_2.00.1.bbappend
new file mode 100644
index 000000000..5283a7841
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/video/liberation-fonts_2.00.1.bbappend
@@ -0,0 +1,9 @@
+
+do_install () {
+ install -d ${D}${datadir}/fonts/ttf/
+ for i in LiberationMono-Regular.ttf; do
+ install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
+ done
+ install -d ${D}${sysconfdir}/fonts/conf.d/
+ install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
+}
diff --git a/meta-phosphor/recipes-phosphor/video/uart-render-controller/uart-render-controller.service b/meta-phosphor/recipes-phosphor/video/uart-render-controller/uart-render-controller.service
new file mode 100644
index 000000000..3fd688f31
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/video/uart-render-controller/uart-render-controller.service
@@ -0,0 +1,14 @@
+
+[Unit]
+Description=UART render controller
+Requires=xyz.openbmc_project.State.Host.service
+After=xyz.openbmc_project.State.Host.service
+
+[Service]
+ExecStart=/usr/sbin/obmc-uart-render-controller \
+ /sys/devices/platform/ahb/ahb:apb/1e6e2000.syscon/1e6e2000.syscon:scratch/vga0 \
+ /sys/devices/platform/ahb/ahb:apb/1e6e2000.syscon/1e6e2000.syscon:scratch/dac_mux \
+ fbterm.service
+
+[Install]
+WantedBy=obmc-standby.target
diff --git a/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
new file mode 100644
index 000000000..c8780a4e7
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
@@ -0,0 +1,30 @@
+HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller"
+LICENSE = "GPLv2+"
+
+SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master"
+SRC_URI += "file://uart-render-controller.service"
+
+PR = "r1"
+
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools
+inherit pkgconfig
+inherit systemd
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "libsystemd"
+RDEPENDS_${PN} += "fbterm"
+
+SRCREV = "14decab20f621c050760e5f3310f5a960cf21211"
+PV = "0.1+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} += "uart-render-controller.service"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
+}
OpenPOWER on IntegriCloud