summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-mrw-native_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-26 09:58:28 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-27 14:29:03 -0400
commit8f93a297d92e6013bced5bb749929af11eedcb3c (patch)
tree7148ab922d9cc8dcbe6cd99ec33c994a9541eebf /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-mrw-native_git.bb
parent713c4d761c2352201d474234739df788699c6f27 (diff)
downloadtalos-openbmc-8f93a297d92e6013bced5bb749929af11eedcb3c.tar.gz
talos-openbmc-8f93a297d92e6013bced5bb749929af11eedcb3c.zip
meta-phosphor: ipmi-fru-*inventory-mrw-native: rename as git
Rename ipmi-fru-*-inventory-mrw-native as git per OE norms. (From meta-phosphor rev: 94f9c6029a21567b491bece1e7037251da67ff18) Change-Id: I12428d5f229c43c31d0e018056177e8865981876 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-mrw-native_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-mrw-native_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-mrw-native_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-mrw-native_git.bb
new file mode 100644
index 000000000..805b3a7c6
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-mrw-native_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit native
+inherit phosphor-ipmi-fru
+inherit mrw-xml
+
+require phosphor-ipmi-fru.inc
+
+DEPENDS += "mrw-native mrw-perl-tools-native"
+
+# TODO: remove this dependency after the MRW script
+# has been updated to not require the hostfw metadata.
+DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}/git"
+do_install() {
+
+ DEST=${D}${config_datadir}
+ install -d ${DEST}
+
+ ${bindir}/perl-native/perl \
+ ${bindir}/gen_ipmi_fru.pl \
+ -i ${mrw_datadir}/${MRW_XML} \
+ -m ${hostfw_datadir}/config.yaml \
+ -o ${DEST}/config.yaml
+}
OpenPOWER on IntegriCloud