summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:25:51 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 07:44:12 -0400
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/devtools
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadtalos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.gz
talos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.zip
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/devtools')
-rw-r--r--meta-phosphor/recipes-phosphor/devtools/obmc-pydevtools.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/devtools/obmc-pydevtools.bb b/meta-phosphor/recipes-phosphor/devtools/obmc-pydevtools.bb
new file mode 100644
index 000000000..b8911aa53
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/devtools/obmc-pydevtools.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC python devtools"
+DESCRIPTION = "Shortcut scripts for developers."
+PR = "r1"
+
+inherit skeleton-python
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-xml \
+ python-pygobject \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ "
+
+SKELETON_DIR = "pytools"
+
+do_install_append() {
+ if [ -f ${S}/obmcutil-completion.sh ]
+ then
+ install -d ${D}${sysconfdir}/profile.d
+ install -m 0644 -D -t ${D}${sysconfdir}/profile.d ${S}/obmcutil-completion.sh
+ fi
+}
OpenPOWER on IntegriCloud