summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/conf
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-17 16:34:24 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-05-05 23:26:24 +0000
commit565e329809329f0bd93baafb3d8dd47d0091c525 (patch)
tree3f08f7bb00094129ae4d7af5e2ca01f102610f11 /meta-phosphor/conf
parentc7b071c9f765d94ef69debfbecb2ff649311dccf (diff)
downloadtalos-openbmc-565e329809329f0bd93baafb3d8dd47d0091c525.tar.gz
talos-openbmc-565e329809329f0bd93baafb3d8dd47d0091c525.zip
Recipes for installing fan definition yaml
This provides the phosphor-fan-control-fan-config virtual to define the fans required by phosphor-fan-control. On systems with the MRW, phosphor-fan-control-fan-config-mrw-native.bb will be used and will run a perl script to generate the yaml from data in the MRW XML. On systems without the MRW, if nothing else is done a default fans.yaml file will be installed into the correct location by phosphor-fan-control-fan-config-native.bb. To install a system specific version, put it into that system's layer along with a .bbappend of this recipe. Change-Id: I36889a33e16a456a04b94aba7326dd674bfd2904 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/conf')
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-defaults.inc13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-phosphor/conf/distro/include/phosphor-defaults.inc b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
index 0ea531b72..53298da68 100644
--- a/meta-phosphor/conf/distro/include/phosphor-defaults.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
@@ -44,6 +44,11 @@ VIRTUAL-RUNTIME_obmc-discover-system-state ?= "phosphor-state-manager-discover"
# Provides implementations of fan presence detection
VIRTUAL-RUNTIME_obmc-fan-presence ?= "phosphor-fan-presence-tach"
+# obmc-fan-control
+#
+# Provides implementations of fan control
+VIRTUAL-RUNTIME_obmc-fan-control ?= "phosphor-fan-control"
+
# obmc-inventory-manager
#
# Provides an implementation of the xyz.openbmc_project.Inventory.Manager
@@ -147,5 +152,13 @@ PREFERRED_PROVIDER_virtual/phosphor-logging-callouts ?= \
PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config ?= \
"${@cf_enabled(d, 'obmc-mrw', 'phosphor-fan-presence-mrw-native', 'phosphor-fan-presence-example-native')}"
+# The phosphor-fan-control application is data driven and requires a YAML
+# file to define the fans in the system.
+# This virtual is a native recipe that provides that definition by installing
+# the YAML file in the format and native sysroot location expected by
+# the phosphor-fan-control build process in the native sysroot.
+PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config ?= \
+ "${@cf_enabled(d, 'obmc-mrw', 'phosphor-fan-control-fan-config-mrw-native', 'phosphor-fan-control-fan-config-native')}"
+
OBMC_DBUS_PATH_ROOT ?= "/xyz/openbmc_project"
OBMC_DBUS_IFACE_ROOT ?= "xyz.openbmc_project"
OpenPOWER on IntegriCloud