summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-11-02 08:40:46 -0600
committerPatrick Williams <patrick@stwcx.xyz>2015-11-02 08:40:46 -0600
commited30fb28c7cded6f9d8fa876086b87d9a8466b54 (patch)
tree934201272a03488e0ce00075ff618924addb2929 /meta-phosphor/common
parent71d42f164a683e8ad27c3dc924ee4f9305a4a7a0 (diff)
parentf2e1684989b264f7f9f8e552cabe7aa0d390d3d5 (diff)
downloadtalos-openbmc-ed30fb28c7cded6f9d8fa876086b87d9a8466b54.tar.gz
talos-openbmc-ed30fb28c7cded6f9d8fa876086b87d9a8466b54.zip
Merge pull request #61 from bradbishop/rest
Update rest-dbus
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/files/makefile.patch24
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/files/no-session-bus.patch12
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/files/resources-path.patch13
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service2
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb13
5 files changed, 6 insertions, 58 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/makefile.patch b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/makefile.patch
deleted file mode 100644
index 96a82c112..000000000
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/makefile.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/Makefile b/Makefile
-new file mode 100644
-index 0000000..3d79547
---- /dev/null
-+++ b/Makefile
-@@ -0,0 +1,18 @@
-+PACKAGE=rest-dbus
-+
-+prefix?=/usr/local
-+bin=$(prefix)/usr/bin
-+share=$(prefix)/usr/share/$(PACKAGE)
-+
-+build clean all:
-+
-+install:
-+ @install -d $(bin) $(share)/resources $(srv)
-+ @install -m 755 $(PACKAGE) $(bin)
-+ @for f in resources/*; do \
-+ install -m644 $$f $(share)/resources; \
-+ done
-+
-+uninstall:
-+ @rm -f $(bin)/$(PACKAGE)
-+ @rm -rf $(share)
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/no-session-bus.patch b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/no-session-bus.patch
deleted file mode 100644
index d68a037ba..000000000
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/no-session-bus.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: git/rest-dbus
-===================================================================
---- git.orig/rest-dbus
-+++ git/rest-dbus
-@@ -8,7 +8,6 @@ import os
- from xml.etree import ElementTree
-
- busses = {
-- 'session': dbus.SessionBus,
- 'system': dbus.SystemBus,
- }
-
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/resources-path.patch b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/resources-path.patch
deleted file mode 100644
index dee44046f..000000000
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/resources-path.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/rest-dbus b/rest-dbus
-index 56ec1f9..078b1cf 100755
---- a/rest-dbus
-+++ b/rest-dbus
-@@ -40,7 +40,7 @@ class DBusRestResourceResponse(DBusRestResponse):
- 'png': 'image/png',
- 'gif': 'image/gif',
- }
-- resource_base = 'resources'
-+ resource_base = '/usr/share/rest-dbus/resources'
-
- def __init__(self, name):
- (_, ext) = os.path.splitext(name)
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service
index 686cf6952..b6f9b978d 100644
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service
+++ b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service
@@ -2,7 +2,7 @@
Description=DBUS introspecting REST server.
[Service]
-ExecStart=/usr/bin/rest-dbus
+ExecStart=/usr/sbin/rest-dbus
[Install]
WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb b/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
index e7e31cf1b..fa551f553 100644
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
@@ -6,24 +6,21 @@ PR = "r1"
inherit allarch
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
+inherit setuptools
RDEPENDS_${PN} += " \
python-netserver \
python-json \
python-dbus \
python-xml \
+ obmc-mapper \
"
+
SRC_URI += " \
git://github.com/openbmc/rest-dbus.git \
- file://makefile.patch \
- file://resources-path.patch \
- file://no-session-bus.patch \
+ file://rest-dbus.service \
"
-SRCREV = "9b0e0bab5150ccc4333ce442932f8969f365155e"
+SRCREV = "b10a57e2f34e94b13697328cc22f876f738feb0e"
S = "${WORKDIR}/git"
-
-do_install() {
- oe_runmake prefix=${D} install
-}
OpenPOWER on IntegriCloud