summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-11-02 16:12:14 -0600
committerPatrick Williams <patrick@stwcx.xyz>2015-11-02 16:12:14 -0600
commit9c3677bc2cc9a73d9ea43ef40abfde61e4deb1d4 (patch)
tree9f47faf02ade35046bc4d756822a61a545a98e39 /meta-phosphor/common
parentfc76ba60a015f367f59a0733422c4318c2df2330 (diff)
parent8f38ad8cdc59490886677bc76cb868c7cb2f5d33 (diff)
downloadtalos-openbmc-9c3677bc2cc9a73d9ea43ef40abfde61e4deb1d4.tar.gz
talos-openbmc-9c3677bc2cc9a73d9ea43ef40abfde61e4deb1d4.zip
Merge pull request #62 from bradbishop/kernelv0.1
Out of (kernel) tree device trees
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
index f49b3fcce..3284fdab9 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
@@ -10,7 +10,7 @@ SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
LINUX_VERSION ?= "4.2"
LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
-SRCREV="openbmc-20151028-1"
+SRCREV="openbmc-20151102-1"
PV = "${LINUX_VERSION}+git${SRCPV}"
@@ -18,3 +18,13 @@ COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
+
+do_patch_append() {
+ for DTB in "${KERNEL_DEVICETREE}"; do
+ DT=`basename ${DTB} .dtb`
+ if [ -r "${WORKDIR}/${DT}.dts" ]; then
+ cp ${WORKDIR}/${DT}.dts \
+ ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
+ fi
+ done
+}
OpenPOWER on IntegriCloud