summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorChris Austen <austenc@us.ibm.com>2015-11-05 20:18:09 -0600
committerChris Austen <austenc@us.ibm.com>2015-11-05 20:18:09 -0600
commit24d2ffa737811d7290ec84cd22fabe476cf0f0dc (patch)
treee8befcefd694b51c0d3885ceaea6b71f7f611910 /meta-phosphor/common
parentd19d16b4d1e2f27841e71c08b548a683a1946df4 (diff)
downloadtalos-openbmc-24d2ffa737811d7290ec84cd22fabe476cf0f0dc.tar.gz
talos-openbmc-24d2ffa737811d7290ec84cd22fabe476cf0f0dc.zip
Add ipmitool for qemu image only
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-tool.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-tool.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-tool.bb
new file mode 100644
index 000000000..2a4d670da
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-tool.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Phosphor ipmi tool for injecting ipmi commands"
+DESCRIPTION = "IPMI Tool with dbus capabilities"
+HOMEPAGE = "https://github.com/openbmc/ipmitool"
+PR = "r1"
+
+
+RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
+
+inherit obmc-phosphor-license
+
+DEPENDS += "systemd \
+ host-ipmid \
+ "
+
+RDEPENDS_${PN} += "libsystemd \
+ libcrypto \
+ "
+
+
+SRC_URI += "git://github.com/openbmc/ipmitool"
+
+SRCREV = "e9b9c1a9677a3de19726d036cfb07d8d61bbccd8"
+
+
+S = "${WORKDIR}/git"
+
+
+do_compile() {
+ ${S}/bootstrap --enable-intf-dbus
+ ${S}/configure --host x86_64
+ make
+}
+
+do_install() {
+ install -m 0755 -d ${D}${sbindir}
+ install -m 0755 ${S}/src/ipmitool ${D}${sbindir}
+}
OpenPOWER on IntegriCloud