summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/users
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-09-06 12:22:28 -0400
committerPatrick Williams <patrick@stwcx.xyz>2016-09-12 18:45:18 +0000
commitdbb9856f262618b8039890b5f7f9a95e68e6c312 (patch)
treeda708793f8104e01bf1b98ad12cc582240754dae /meta-phosphor/common/recipes-phosphor/users
parent194b590eb913cc8463c2c7774865d6bc8b07aa17 (diff)
downloadtalos-openbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.tar.gz
talos-openbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.zip
Drop obmc-phosphor- prefix from recipe collections
Given that these are already in the recipes-phosphor directory this seemed redundant. Change-Id: I48a1ab79e0eda88fc5e6af88f198ca3941e829b8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/users')
-rw-r--r--meta-phosphor/common/recipes-phosphor/users/files/obmc-phosphor-user.service10
-rw-r--r--meta-phosphor/common/recipes-phosphor/users/obmc-phosphor-user.bb31
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/users/files/obmc-phosphor-user.service b/meta-phosphor/common/recipes-phosphor/users/files/obmc-phosphor-user.service
new file mode 100644
index 000000000..7c1ffce13
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/users/files/obmc-phosphor-user.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Phosphor OpenBMC user management daemon
+
+[Service]
+ExecStart=/usr/sbin/obmc-phosphor-userd
+Environment="PYTHONUNBUFFERED=1"
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/users/obmc-phosphor-user.bb b/meta-phosphor/common/recipes-phosphor/users/obmc-phosphor-user.bb
new file mode 100644
index 000000000..f1f589b1e
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/users/obmc-phosphor-user.bb
@@ -0,0 +1,31 @@
+SUMMARY = "User DBUS object"
+DESCRIPTION = "User DBUS object"
+HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-user-mgmt
+inherit obmc-phosphor-systemd
+
+RDEPENDS_${PN} += "python-dbus python-pygobject python-pexpect"
+
+SRC_URI += "git://github.com/openbmc/phosphor-networkd"
+
+SRCREV = "53b692b2365e924025fce0ebc2be4242e77b48ca"
+
+S = "${WORKDIR}/git"
+INSTALL_NAME = "userman.py"
+
+# Since base_do_compile finds a makefile (from networkd) it tries to
+# compile. Short-circuit that because we just need to copy a python
+# file in this package.
+do_compile() {
+ :
+}
+
+do_install() {
+echo "***installing $INSTALL_NAME"
+ install -d ${D}/${sbindir}
+ install ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-userd
+}
+
OpenPOWER on IntegriCloud