summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2015-10-19 14:15:04 -0400
committerBrad Bishop <bradleyb@us.ibm.com>2015-10-19 14:15:59 -0400
commit6161f459cfcc1dafbcbc1de3ad9ca36555fb9dc5 (patch)
tree27eb38682c7f61268b68881be7357097b175ce48 /meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
parent935b1442c04eb97a3a9d67758e687645340d1dad (diff)
downloadtalos-openbmc-6161f459cfcc1dafbcbc1de3ad9ca36555fb9dc5.tar.gz
talos-openbmc-6161f459cfcc1dafbcbc1de3ad9ca36555fb9dc5.zip
Add skeleton recipe
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
new file mode 100644
index 000000000..ccc5ed1f0
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Temp placeholder for skeleton function"
+DESCRIPTION = "Temp placeholder for skeleton repository"
+HOMEPAGE = "http://github.com/openbmc/skeleton"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+DEPENDS += "glib-2.0"
+RDEPENDS_${PN} += "python-subprocess"
+SRC_URI += "git://github.com/openbmc/skeleton"
+
+SRCREV = "18d4591170779ceb81158c650d31c6c59115b2f2"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}/${sbindir} ${D}${libdir}
+ for i in ${S}/bin/*.py ${S}/bin/*.exe ${S}/bin/tftpy/*.py; do
+ install $i ${D}/${sbindir}
+ done
+ install ${S}/bin/libopenbmc_intf.so ${D}/${libdir}
+}
OpenPOWER on IntegriCloud