summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-04-01 15:04:31 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-04-14 16:58:20 -0500
commite0d4a8f1ad4fbaa6bdf48890d5f5475df4ece3c2 (patch)
tree4c649e15d394b4344fe29f06fcc1d0121f270f28 /meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
parent7fcf0de959e325865af14274d15da493241da73b (diff)
downloadtalos-openbmc-e0d4a8f1ad4fbaa6bdf48890d5f5475df4ece3c2.tar.gz
talos-openbmc-e0d4a8f1ad4fbaa6bdf48890d5f5475df4ece3c2.zip
skeleton: Use pflash recipe
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
index 08e4d33a3..551843eab 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
@@ -16,12 +16,19 @@ DEPENDS += "glib-2.0 systemd"
RDEPENDS_${PN} += "python-subprocess python-compression libsystemd"
SRC_URI += "git://github.com/openbmc/skeleton"
+# RDEPEND on pflash if the openpower-pflash machine feature is set.
+PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}"
+PACKAGECONFIG[openpower-pflash] = ",,,pflash"
+
SRCREV = "27ca44ad1a96f90d42dcb50183700e5ca5358642"
S = "${WORKDIR}"
do_compile() {
oe_runmake -C git
+
+ # Remove deprecated files.
+ rm ${S}/git/bin/pflash
}
do_install() {
OpenPOWER on IntegriCloud