summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2015-10-29 11:14:29 -0500
committerAdriana Kobylak <anoo@us.ibm.com>2015-10-29 11:24:37 -0500
commit75b8b382e4bc362052707432e938fc323724cf66 (patch)
tree6948ee8d052109291685c64b4039c8e351dd5092 /meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
parent86bc4951e8c3b476a84dc8cef950a1a81cc532dc (diff)
downloadtalos-openbmc-75b8b382e4bc362052707432e938fc323724cf66.tar.gz
talos-openbmc-75b8b382e4bc362052707432e938fc323724cf66.zip
Update skeleton version to pick up new executables
Update skeleton commit version in the recipe Get executables from bin and libraries from lib
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
index 0c8687c92..572030c53 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
@@ -17,20 +17,22 @@ DEPENDS += "glib-2.0"
RDEPENDS_${PN} += "python-subprocess python-tftpy"
SRC_URI += "git://github.com/openbmc/skeleton"
-SRCREV = "47750bc1c06aebda189f2e8d7862c9d9b9ffe35b"
+SRCREV = "597d49e68e8bf0ddedb2e01cbd3fb500ee1c22e3"
S = "${WORKDIR}"
do_compile() {
- oe_runmake -C git all
+ oe_runmake -C git
}
do_install() {
source=${S}/git
install -d ${D}/${sbindir} ${D}${libdir}
- for i in ${source}/bin/*.py ${source}/bin/*.exe; do
+ for i in ${source}/bin/*; do
install $i ${D}/${sbindir}
done
- install ${source}/bin/libopenbmc_intf.so ${D}/${libdir}
+ for i in ${source}/lib/*; do
+ install $i ${D}/${libdir}
+ done
}
OpenPOWER on IntegriCloud