summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-09 22:22:46 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-15 11:00:31 -0400
commit65b40a80454bc22d0e4e1f4fafcd43d33a7167b8 (patch)
tree7fb8e2a547f3f5fbf070c936a88ad7715cb2f066 /meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
parenta9a69fa5572d95eb2a9041e8fd2bcbdf024a332d (diff)
downloadtalos-openbmc-65b40a80454bc22d0e4e1f4fafcd43d33a7167b8.tar.gz
talos-openbmc-65b40a80454bc22d0e4e1f4fafcd43d33a7167b8.zip
Add virtual workbook / config-in-skeleton classes
This patch introduces a new abstraction 'skeleton-workbook' for representing a system configuration. At present it is pulled in by the skeleton recipe so the requirement on what is implemented by a package providing obmc-phosphor-workbook is something compatible with the existing System.py python modules in skeleton. Additionally this patch adds a new recipe for each system using a configuration file from skeleton today, and a class for common configuration. This enables a couple of things: - No need to patch skeleton.service for each system. - New systems don't have to put their configuration in the skeleton repository. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
index eb45a406c..97627925e 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
@@ -14,8 +14,10 @@ inherit obmc-phosphor-system-mgmt
inherit pythonnative
inherit python-dir
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
DEPENDS += "glib-2.0 systemd"
-RDEPENDS_${PN} += "python-subprocess python-compression libsystemd"
+RDEPENDS_${PN} += "python-subprocess python-compression libsystemd ${VIRTUAL-RUNTIME_skeleton_workbook}"
SRC_URI += "git://github.com/openbmc/skeleton"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*"
@@ -41,7 +43,7 @@ do_compile() {
do_install() {
oe_runmake -C git install \
- PYTHON=${PYTHON} \
- DESTDIR=${D} \
- PREFIX=/usr
+ PYTHON=${PYTHON} \
+ DESTDIR=${D} \
+ PREFIX=/usr
}
OpenPOWER on IntegriCloud