summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@us.ibm.com>2015-10-28 08:13:43 -0500
committerBrad Bishop <bradleyb@us.ibm.com>2015-10-28 08:13:43 -0500
commit59ca1fd41470b3723b773ed90a8237c45cdcd0bc (patch)
treee8b4693528ef16cbb1adbc5dbe148cb802091752 /meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
parent707303e60eb6c10387cfe1c93cbb75c56984df5e (diff)
downloadtalos-openbmc-59ca1fd41470b3723b773ed90a8237c45cdcd0bc.tar.gz
talos-openbmc-59ca1fd41470b3723b773ed90a8237c45cdcd0bc.zip
Don't set source dir to git
So that patches can apply.
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
index d0cf359d6..0c8687c92 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
@@ -19,16 +19,18 @@ SRC_URI += "git://github.com/openbmc/skeleton"
SRCREV = "47750bc1c06aebda189f2e8d7862c9d9b9ffe35b"
-S = "${WORKDIR}/git"
+S = "${WORKDIR}"
do_compile() {
- oe_runmake all
+ oe_runmake -C git all
}
do_install() {
+ source=${S}/git
+
install -d ${D}/${sbindir} ${D}${libdir}
- for i in ${S}/bin/*.py ${S}/bin/*.exe; do
+ for i in ${source}/bin/*.py ${source}/bin/*.exe; do
install $i ${D}/${sbindir}
done
- install ${S}/bin/libopenbmc_intf.so ${D}/${libdir}
+ install ${source}/bin/libopenbmc_intf.so ${D}/${libdir}
}
OpenPOWER on IntegriCloud