summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/settings
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2016-01-30 08:53:35 -0600
committerAdriana Kobylak <anoo@us.ibm.com>2016-01-30 08:53:35 -0600
commite2374b01b753efc830679a87552d1320e092f039 (patch)
treed070354d89bebddc446a230c46e2f10e8ead8dab /meta-phosphor/common/recipes-phosphor/settings
parent12aaa75468b4cf08370d57f870f9d2ab0b9b7847 (diff)
downloadtalos-openbmc-e2374b01b753efc830679a87552d1320e092f039.tar.gz
talos-openbmc-e2374b01b753efc830679a87552d1320e092f039.zip
Add settings dbus object to openbmc image
Create settings recipe and service files Add dependency to settings to the ipmid recipe since the upcoming ipmi boot flags use this settings dbus object
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/settings')
-rw-r--r--meta-phosphor/common/recipes-phosphor/settings/settings.bb22
-rwxr-xr-xmeta-phosphor/common/recipes-phosphor/settings/settings/settings.service10
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/settings/settings.bb b/meta-phosphor/common/recipes-phosphor/settings/settings.bb
new file mode 100644
index 000000000..1c5fe2844
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/settings/settings.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Settings DBUS object"
+DESCRIPTION = "Settings DBUS object"
+HOMEPAGE = "http://github.com/openbmc/phosphor-settingsd"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+RDEPENDS_${PN} += "python-dbus python-pygobject"
+
+SRC_URI += "git://github.com/openbmc/phosphor-settingsd"
+
+SRCREV = "33e0930724c12f83ddf99f7452fc0551ac10ccfc"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install ${S}/settings_file.py ${D}/${sbindir}
+ install ${S}/settings_manager.py ${D}/${sbindir}
+}
+
diff --git a/meta-phosphor/common/recipes-phosphor/settings/settings/settings.service b/meta-phosphor/common/recipes-phosphor/settings/settings/settings.service
new file mode 100755
index 000000000..24c4a5a31
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/settings/settings/settings.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Settings DBUS Object
+Requires=skeleton.service
+After=skeleton.service
+
+[Service]
+ExecStart=/usr/sbin/settings_manager.py
+
+[Install]
+WantedBy=multi-user.target
OpenPOWER on IntegriCloud