summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/sensors
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-09-06 12:22:28 -0400
committerPatrick Williams <patrick@stwcx.xyz>2016-09-12 18:45:18 +0000
commitdbb9856f262618b8039890b5f7f9a95e68e6c312 (patch)
treeda708793f8104e01bf1b98ad12cc582240754dae /meta-phosphor/common/recipes-phosphor/sensors
parent194b590eb913cc8463c2c7774865d6bc8b07aa17 (diff)
downloadtalos-openbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.tar.gz
talos-openbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.zip
Drop obmc-phosphor- prefix from recipe collections
Given that these are already in the recipes-phosphor directory this seemed redundant. Change-Id: I48a1ab79e0eda88fc5e6af88f198ca3941e829b8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/sensors')
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.py29
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.service9
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon.bb24
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon/obmc-hwmon.service13
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor.bb19
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor/org.openbmc.Sensors.service12
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/obmc-phosphor-sensord.bb9
7 files changed, 115 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.py b/meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.py
new file mode 100644
index 000000000..c9771acb4
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+
+# Contributors Listed Below - COPYRIGHT 2015
+# [+] International Business Machines Corp.
+#
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied. See the License for the specific language governing
+# permissions and limitations under the License.
+
+import time
+import sys
+import dbus
+import dbus.service
+import dbus.mainloop.glib
+
+if __name__ == '__main__':
+ print "obmc-phosphor-sensord starting..."
+
+ while 1:
+ time.sleep(5)
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.service b/meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.service
new file mode 100644
index 000000000..247164feb
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/files/obmc-phosphor-sensord.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Phosphor OpenBMC sensor management daemon
+
+[Service]
+Restart=always
+ExecStart=/usr/sbin/obmc-phosphor-sensord
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon.bb b/meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon.bb
new file mode 100644
index 000000000..0e555b8cc
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon.bb
@@ -0,0 +1,24 @@
+SUMMARY = "OpenBMC hwmon poller"
+DESCRIPTION = "OpenBMC hwmon poller."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-systemd
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-shell \
+ python-pygobject \
+ pyphosphor-dbus \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ "
+
+SKELETON_DIR = "pyhwmon"
+TMPL = "mapper-wait@.service"
+TGT = "obmc-fans-ready.target"
+INSTFMT = "mapper-wait@-org-openbmc-sensors-speed-fan{0}.service"
+FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_FAN_INSTANCES')}"
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon/obmc-hwmon.service b/meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon/obmc-hwmon.service
new file mode 100644
index 000000000..806ce1310
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/obmc-hwmon/obmc-hwmon.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Phosphor Hwmon Poller
+Wants=mapper-wait@-org-openbmc-sensors.service
+After=mapper-wait@-org-openbmc-sensors.service
+Before=obmc-fans-ready.target
+
+[Service]
+Restart=always
+ExecStart={sbindir}/hwmon.py
+Environment="PYTHONUNBUFFERED=1"
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor.bb b/meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor.bb
new file mode 100644
index 000000000..3b77460cf
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor.bb
@@ -0,0 +1,19 @@
+SUMMARY = "OpenBMC sensor manager"
+DESCRIPTION = "OpenBMC sensor manager."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-pygobject\
+ pyphosphor-dbus \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ "
+
+SKELETON_DIR = "pysensormgr"
+DBUS_SERVICE_${PN} += "org.openbmc.Sensors.service"
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor/org.openbmc.Sensors.service b/meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor/org.openbmc.Sensors.service
new file mode 100644
index 000000000..4fa5a5a75
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/obmc-mgr-sensor/org.openbmc.Sensors.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Phosphor Sensor Manager
+
+[Service]
+Restart=always
+ExecStart={sbindir}/sensor_manager2.py
+Type=dbus
+BusName={BUSNAME}
+Environment="PYTHONUNBUFFERED=1"
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/obmc-phosphor-sensord.bb b/meta-phosphor/common/recipes-phosphor/sensors/obmc-phosphor-sensord.bb
new file mode 100644
index 000000000..7a82fb5bc
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/obmc-phosphor-sensord.bb
@@ -0,0 +1,9 @@
+SUMMARY = "Phosphor OpenBMC Sensor Management"
+DESCRIPTION = "Phosphor OpenBMC sensor management reference implementation."
+PR = "r1"
+
+inherit obmc-phosphor-sensor-mgmt
+inherit obmc-phosphor-pydbus-service
+
+S = "${WORKDIR}"
+SRC_URI += "file://${PN}.py"
OpenPOWER on IntegriCloud