summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/sensors
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-02-22 20:50:13 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-02-24 16:51:24 +0000
commit3217b271500e887b01241da3f4f43f27b9c6ac5d (patch)
tree41004653feb9f288dfaec7fb96f56dc3f14874f0 /meta-phosphor/common/recipes-phosphor/sensors
parentae46d563088822a0100cae5f5d9a6192afc1d5c8 (diff)
downloadtalos-openbmc-3217b271500e887b01241da3f4f43f27b9c6ac5d.tar.gz
talos-openbmc-3217b271500e887b01241da3f4f43f27b9c6ac5d.zip
Change how hwmon.pl is invoked for MRW systems
This minor tweak removes the need for MRW using systems to append the phosphor-hwmon recipe in their layer. Change-Id: I3d9dcfff452e26d191df37ae7d759c6c2c3f2cd4 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/sensors')
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb45
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon.bb2
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb b/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
new file mode 100644
index 000000000..d72d5036b
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Phosphor hwmon configuration generator"
+DESCRIPTION = "Generate phosphor-hwmon configuration from an MRW."
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit allarch
+
+DEPENDS += "mrw-perl-tools-native mrw-native"
+
+do_compile_append() {
+ ${STAGING_BINDIR_NATIVE}/perl-native/perl \
+ ${STAGING_BINDIR_NATIVE}/hwmon.pl \
+ -x ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml
+}
+
+def find_conf_files():
+ from fnmatch import fnmatch
+ myfiles = []
+
+ #These conf files generated by hwmon.pl are in
+ #subdirectories which we need to preserve the path to.
+ for root, dirs, files in os.walk("./"):
+ for name in files:
+ if fnmatch(name, "*.conf"):
+ myfiles.append(os.path.join(root, name))
+
+ return myfiles
+
+python install_conf_files() {
+ from shutil import copy
+
+ files = find_conf_files()
+
+ install_dir = os.path.join(d.getVar("D", True),
+ "etc", "default", "obmc", "hwmon")
+ for f in files:
+ dest = os.path.join(install_dir, f)
+ parent = os.path.dirname(dest)
+ if not os.path.exists(parent):
+ os.makedirs(parent)
+
+ copy(f, dest)
+}
+
+do_install[postfuncs] += "install_conf_files"
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon.bb b/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon.bb
index d7a2d6df6..11e968feb 100644
--- a/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon.bb
+++ b/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon.bb
@@ -23,6 +23,8 @@ RDEPENDS_${PN} += "\
phosphor-logging \
"
+RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
+
SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
SRC_URI += "file://70-hwmon.rules"
OpenPOWER on IntegriCloud