summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/sensors
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-07 23:30:32 -0400
committerPatrick Williams <patrick@stwcx.xyz>2017-06-12 12:23:37 +0000
commit096d818cca0ef3c32b1e1de20ec8430d1e7fe195 (patch)
tree24d552f9a11cfd63d43a2ce34fa5396bd5cd9995 /meta-phosphor/common/recipes-phosphor/sensors
parent5b42b7457a53a874a2f1517cd5a3d1b83842260c (diff)
downloadtalos-openbmc-096d818cca0ef3c32b1e1de20ec8430d1e7fe195.tar.gz
talos-openbmc-096d818cca0ef3c32b1e1de20ec8430d1e7fe195.zip
MRW: avoid recursive install of hwmon configs
Fix an issue where any hwmon conf file under WORKDIR is installed in the image. If hwmon-config-mrw is run multiple times, subsequent bakes will install conf files under image, packages-split, etc into the image. Install MRW generated hwmon configs in a directory under WORKDIR. Point the config file search algorithm at this directory, rather than WORKDIR to avoid finding configuration files installed into image, packages-split, etc...from previous bakes. Change-Id: I569092af4033935cc6113e101c8ec7e37b5849c9 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/sensors')
-rw-r--r--meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb b/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
index e667a7a9c..7e016b51d 100644
--- a/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
+++ b/meta-phosphor/common/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
@@ -11,7 +11,7 @@ do_compile_append() {
${STAGING_BINDIR_NATIVE}/perl-native/perl \
${STAGING_BINDIR_NATIVE}/hwmon.pl \
-x ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml \
- -d ${WORKDIR}
+ -d ${WORKDIR}/mrw-config-files
}
def find_conf_files(dir):
@@ -30,12 +30,15 @@ def find_conf_files(dir):
python install_conf_files() {
from shutil import copy
- files = find_conf_files(d.getVar("WORKDIR", True))
+ conf_file_dir = os.path.join(
+ d.getVar("WORKDIR", True),
+ 'mrw-config-files')
+ files = find_conf_files(conf_file_dir)
install_dir = os.path.join(d.getVar("D", True),
"etc", "default", "obmc", "hwmon")
- dir_len = len(d.getVar("WORKDIR", True))
+ dir_len = len(conf_file_dir)
for f in files:
dest = os.path.join(install_dir, f[dir_len + 1:])
OpenPOWER on IntegriCloud