summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-03-01 16:16:06 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-03-06 17:21:19 +0000
commitdb32a7c5dc0f3318553444496360a25fa4cd99d2 (patch)
treeea8274124133aa0e1b50bbb86bb23e15384270d0 /meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
parent2cac4f7b07b4f0ca275048da76986055cee542d2 (diff)
downloadtalos-openbmc-db32a7c5dc0f3318553444496360a25fa4cd99d2.tar.gz
talos-openbmc-db32a7c5dc0f3318553444496360a25fa4cd99d2.zip
image: Use VIRTUAL-RUNTIME for state pkgs
The correct idiom for modeling runtime only virtual implementations with no build time API is to use VIRTUAL-RUNTIME in favor of PREFERRED_PROVIDER. Update the state management management applications accordingly since they fall into this category. Change-Id: I8f0092a38da4ea0741dd0f464b71f4ea12d12019 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index 556d79d33..517a679d4 100644
--- a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -7,14 +7,27 @@ inherit obmc-phosphor-license
PROVIDES = "${PACKAGES}"
PACKAGES = " \
+ ${PN}-bmc-state-mgmt \
+ ${PN}-chassis-state-mgmt \
${PN}-extras \
${PN}-extrasdev \
+ ${PN}-host-state-mgmt \
${PN}-inventory \
${PN}-leds \
${PN}-sensors \
${PN}-software \
"
+SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
+RDEPENDS_${PN}-bmc-state-mgmt = " \
+ ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
+ "
+
+SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
+RDEPENDS_${PN}-chassis-state-mgmt = " \
+ ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
+ "
+
SUMMARY_${PN}-extras = "Extra features"
RDEPENDS_${PN}-extras = " \
phosphor-rest \
@@ -25,6 +38,11 @@ RDEPENDS_${PN}-extrasdev = " \
rest-dbus \
"
+SUMMARY_${PN}-host-state-mgmt = "Host state management"
+RDEPENDS_${PN}-host-state-mgmt = " \
+ ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
+ "
+
SUMMARY_${PN}-inventory = "Inventory applications"
RDEPENDS_${PN}-inventory = " \
${VIRTUAL-RUNTIME_obmc-inventory-manager} \
OpenPOWER on IntegriCloud