summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/mrw
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2016-07-26 11:28:41 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-09-07 13:48:38 +0000
commitfe0d5d30509c829b4cb09ae9845873c398ed3239 (patch)
tree85806e81ffed35b809f20513c8c17157738a9ee1 /meta-phosphor/common/recipes-phosphor/mrw
parentc2f32db6de3ade3710ca359c56b095586bb64c5b (diff)
downloadtalos-openbmc-fe0d5d30509c829b4cb09ae9845873c398ed3239.tar.gz
talos-openbmc-fe0d5d30509c829b4cb09ae9845873c398ed3239.zip
Add machine readable workbook recipe.
Add a recipe that will pull down the MRW XML file <machine>.xml and install it into the fakeroot in /usr/share/obmc-mrw so it's available for other components to process. It gets the SRC_URI from PHOSPHOR_MRW_URI, which would be set by the <machine>.conf file ideally. Change-Id: I351a9a0a88f709085df53da96bccb3d8db145de4 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
new file mode 100644
index 000000000..3ce4c9799
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook"
+DESCRIPTION = "Pulls down system specific data"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit native
+
+PHOSPHOR_MRW_URI ?= "http://missing-mrw-uri"
+SRC_URI += "${PHOSPHOR_MRW_URI}"
+SRCREV = "${PHOSPHOR_MRW_REV}"
+
+do_install() {
+ install -d ${datadir}/obmc-mrw
+ install -m 0644 ${MACHINE}.xml ${datadir}/obmc-mrw
+}
+
OpenPOWER on IntegriCloud