summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/mrw
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2016-09-20 13:32:44 -0500
committerMatt Spinler <spinler@us.ibm.com>2016-09-20 13:32:44 -0500
commit98c33e335d3f0d99e5d754251bccce9c5ba64113 (patch)
tree674db3e2f9965e4afa8866fe7c5b38d9c92f266d /meta-phosphor/common/recipes-phosphor/mrw
parent5d5f8df3ecf64104ba4734d09659eae997a7a722 (diff)
downloadtalos-openbmc-98c33e335d3f0d99e5d754251bccce9c5ba64113.tar.gz
talos-openbmc-98c33e335d3f0d99e5d754251bccce9c5ba64113.zip
Fix MRW native installs paths
How it was before could cause problems in Jenkins. Change-Id: I33cf31fc79c995b4609f77eeac1896d3812d276b Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb4
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb4
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb4
3 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
index ec1df89a3..01bff6186 100644
--- a/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
@@ -15,6 +15,6 @@ SRC_URI += "git://github.com/open-power/serverwiz.git;subpath=scripts"
SRCREV = "04f15f37e9ab6c09412a0abcffb87e9aefcc5368"
do_install() {
- install -d ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
- install -m 0755 Targets.pm ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+ install -d ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
+ install -m 0755 Targets.pm ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
}
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
index e06a68298..12a9b9e78 100644
--- a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
@@ -13,7 +13,7 @@ SRC_URI += "${PHOSPHOR_MRW_URI}"
SRCREV = "${PHOSPHOR_MRW_REV}"
do_install() {
- install -d ${datadir}/obmc-mrw
- install -m 0644 ${MACHINE}.xml ${datadir}/obmc-mrw
+ install -d ${D}${datadir}/obmc-mrw
+ install -m 0644 ${MACHINE}.xml ${D}${datadir}/obmc-mrw
}
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb
index 737944250..05d5baa95 100644
--- a/meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb
@@ -13,6 +13,6 @@ SRC_URI += "git://github.com/openbmc/phosphor-mrw-tools"
SRCREV = "7a68567af7bf121143ef135152a39723518b6e06"
do_install() {
- install -d ${bindir}/obmc-mrw
- install -m 0755 patchxml.py ${bindir}/obmc-mrw
+ install -d ${D}${bindir}/obmc-mrw
+ install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw
}
OpenPOWER on IntegriCloud