summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/mrw
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2016-10-17 11:20:01 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-11-08 00:53:51 +0000
commit6ce8962d66ab521a9a5940eec0409b1c552d83df (patch)
tree6011c1a5b4557bb939a3fb53ec55893ebabf2f47 /meta-phosphor/common/recipes-phosphor/mrw
parentdadd4763e0f9b79a56a5afd975d76a0c0da90932 (diff)
downloadtalos-openbmc-6ce8962d66ab521a9a5940eec0409b1c552d83df.tar.gz
talos-openbmc-6ce8962d66ab521a9a5940eec0409b1c552d83df.zip
Add recipe to install device tree generator script
Change-Id: I70677db17e3fef94243b1d77ffd54c897ab2f6f8 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-devtree-native.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-devtree-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-devtree-native.bb
new file mode 100644
index 000000000..c94da304c
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-devtree-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor Device Tree Generator"
+DESCRIPTION = "Script to generate the BMC device tree from the MRW XML"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit native
+inherit mrw-rev
+
+DEPENDS += "yaml-tiny mrw-api-native"
+
+SRC_URI += "${MRW_TOOLS_SRC_URI}"
+SRCREV = "${MRW_TOOLS_SRCREV}"
+
+do_install() {
+ install -d ${D}${STAGING_BINDIR_NATIVE}
+ install -m 0755 gen_devtree.pl ${D}${STAGING_BINDIR_NATIVE}/gen_devtree.pl
+}
OpenPOWER on IntegriCloud