summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/mrw
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2016-08-12 12:52:36 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-09-09 14:16:30 +0000
commit1e3c41430bb7536ef0f91e507c3134b5ce003d8a (patch)
tree02338377f7e45fe5ae94b54775c05393f6f44efb /meta-phosphor/common/recipes-phosphor/mrw
parent1042e936d46edb3e4e1e696d69b62f011814ad17 (diff)
downloadtalos-openbmc-1e3c41430bb7536ef0f91e507c3134b5ce003d8a.tar.gz
talos-openbmc-1e3c41430bb7536ef0f91e507c3134b5ce003d8a.zip
Add API module for the machine readable workbook XML.
This recipe provides Targets.pm, which should be used to parse the XML generated by the Serverwiz MRW tool. Change-Id: I4d28f8b0dd2b8e3519c1ba007dfc9b77e83438f8 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
new file mode 100644
index 000000000..ec1df89a3
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
+DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
+PR = "r1"
+
+S = "${WORKDIR}/scripts"
+
+inherit obmc-phosphor-license
+inherit native
+inherit perlnative
+inherit cpan-base
+
+DEPENDS += "libxml-simple-perl-native json-perl-native"
+
+SRC_URI += "git://github.com/open-power/serverwiz.git;subpath=scripts"
+SRCREV = "04f15f37e9ab6c09412a0abcffb87e9aefcc5368"
+
+do_install() {
+ install -d ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
+ install -m 0755 Targets.pm ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+}
OpenPOWER on IntegriCloud