summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/mrw
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2016-08-25 13:04:09 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-09-13 18:15:51 +0000
commit1b8b9042df9bf87054a91891ef7513900b2b1eda (patch)
treeb6797e3314c197c9ee457ec92e76f06583d5f795 /meta-phosphor/common/recipes-phosphor/mrw
parent3337d89d2a020bb6657cdc328cf307ce0b113346 (diff)
downloadtalos-openbmc-1b8b9042df9bf87054a91891ef7513900b2b1eda.tar.gz
talos-openbmc-1b8b9042df9bf87054a91891ef7513900b2b1eda.zip
Add XML patching bitbake class.
This commit adds a new obmc-xmlpatch class that can be inherited in a recipe to provide a do_patch task to patch XML files. The patch files are themselves XML, and must end in .patch.xml for do_patch to find them. This commit also includes Palmetto patches specified in palmetto.xml.patch.xml that are required to build the system inventory. Change-Id: Idae6ffd8e7a3aa247115ff3a840e047727ff0d1a Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb1
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
index 3ce4c9799..e06a68298 100644
--- a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
@@ -5,6 +5,7 @@ PR = "r1"
S = "${WORKDIR}/git"
inherit obmc-phosphor-license
+inherit obmc-xmlpatch
inherit native
PHOSPHOR_MRW_URI ?= "http://missing-mrw-uri"
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb
new file mode 100644
index 000000000..694ece9ed
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-patch-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor machine readable workbook patching script"
+DESCRIPTION = "Retrieve the script that can patch the MRW XML"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit native
+
+DEPENDS += "python-native python-lxml-native"
+
+SRC_URI += "git://github.com/openbmc/phosphor-mrw-tools"
+SRCREV = "ab015d7e2a2eb87eab2ca7d731ebcb7a873442e9"
+
+do_install() {
+ install -d ${bindir}/obmc-mrw
+ install -m 0755 patchxml.py ${bindir}/obmc-mrw
+}
OpenPOWER on IntegriCloud