summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/leds
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-24 16:16:14 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-01-26 03:42:40 +0000
commit2079009427ddcccfe684bc4977422d4c707086f9 (patch)
tree420bd22a4136aa477b618b1e65c593eec129ce22 /meta-phosphor/common/recipes-phosphor/leds
parentb80be13d826ca320556cfaf2c30830b11e11c7a2 (diff)
downloadtalos-openbmc-2079009427ddcccfe684bc4977422d4c707086f9.tar.gz
talos-openbmc-2079009427ddcccfe684bc4977422d4c707086f9.zip
Moved phosphor-led-foo to the leds folder
There is already a folder for led related recipes. Change-Id: Ic137555b04786844831ec9ff08f3b0488d111293 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/leds')
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb20
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager/xyz.openbmc_project.ledmanager.service12
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-led-sysfs.bb16
3 files changed, 48 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb
new file mode 100644
index 000000000..a2c8a8335
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor LED Group Management Daemon"
+DESCRIPTION = "Daemon to cater to triggering actions on LED groups"
+HOMEPAGE = "http://github.com/openbmc/phosphor-led-manager"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+inherit pythonnative
+inherit autotools pkgconfig
+
+DEPENDS += "python-pyyaml-native"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+RDEPENDS_${PN} += "libsystemd"
+
+SRC_URI += "git://github.com/openbmc/phosphor-led-manager"
+SRCREV = "ed4907342897301ab96cbf2c617cafd78caf25a1"
+S = "${WORKDIR}/git"
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.ledmanager.service"
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager/xyz.openbmc_project.ledmanager.service b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager/xyz.openbmc_project.ledmanager.service
new file mode 100644
index 000000000..0492c44ec
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager/xyz.openbmc_project.ledmanager.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Phosphor LED Group Management Daemon
+Before=mapper-wait@-xyz-openbmc_project-ledmanager-groups.service
+
+[Service]
+Restart=always
+ExecStart={sbindir}/phosphor-ledmanager
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-sysfs.bb b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-sysfs.bb
new file mode 100644
index 000000000..1ccb02a23
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-sysfs.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Phosphor Physical LED Controller daemon"
+DESCRIPTION = "Daemon to trigger actions on a physical LED"
+HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+inherit autotools pkgconfig
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+RDEPENDS_${PN} += "libsystemd"
+
+SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs"
+SRCREV = "61675c3265166cecb0f8f5c2c4f80a78d3412c25"
+S = "${WORKDIR}/git"
OpenPOWER on IntegriCloud