summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2017-03-06 17:05:11 +0530
committerRatan Gupta <ratagupt@in.ibm.com>2017-03-16 14:32:36 +0530
commit3aa591fe9b9509fbdb0ea41ae6763448393294ac (patch)
tree74b0b1ece6639d39b6cabe6f35b2079643875e96 /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
parentf0a463adf45dc2baedd2e5d60a22dd41827781eb (diff)
downloadtalos-openbmc-3aa591fe9b9509fbdb0ea41ae6763448393294ac.tar.gz
talos-openbmc-3aa591fe9b9509fbdb0ea41ae6763448393294ac.zip
Add virtual/phosphor-ipmi-sensor-inventory
This virtual provides a YAML file that serves as sensor inventory configuration for phosphor-host-ipmid. Add a native recipe that builds the configuration from MRW. Set this recipe as the default for OpenPOWER systems. Resolves openbmc/openbmc#781 Resolves openbmc/openbmc#1212 Change-Id: I25034dd3ed825e2ef320ab0b38ac2f733afded47 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
new file mode 100644
index 000000000..284369d65
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
@@ -0,0 +1,28 @@
+SUMMARY = "sensor config for phosphor-host-ipmid"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-host
+
+SRC_URI += "file://config.yaml"
+
+DEPENDS += " \
+ mrw-native \
+ mrw-perl-tools-native \
+ "
+
+PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${config_datadir}
+ install -d ${DEST}
+
+ ${bindir}/perl-native/perl \
+ ${bindir}/gen_ipmi_sensor.pl \
+ -i ${datadir}/obmc-mrw/${MACHINE}.xml \
+ -m config.yaml \
+ -o ${DEST}/sensor.yaml
+}
OpenPOWER on IntegriCloud