summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
diff options
context:
space:
mode:
authorKun Yi <kunyi@google.com>2017-10-09 23:17:08 -0700
committerKun Yi <kunyi@google.com>2017-10-18 14:18:50 -0700
commitcdc3b23921bc2804b06abd6812839c84e01cec80 (patch)
tree6d3f0b21d4d641b34ca50d044c1f1ff66af94249 /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
parent2a595c5906c85313829b026e3c995e59d43d11a2 (diff)
downloadtalos-openbmc-cdc3b23921bc2804b06abd6812839c84e01cec80.tar.gz
talos-openbmc-cdc3b23921bc2804b06abd6812839c84e01cec80.zip
Fix YAML overriding.
bitbake tasks use python3, under which filter() returns a filter object which doesn't enumerate as list. As a result none of the overriding YAMLs takes effect. Use list expansion instead. Discussion for context: https://lists.ozlabs.org/pipermail/openbmc/2017-October/009521.html Fixes openbmc/openbmc#2469. Change-Id: I37cc7fc14b6f91c4eb1fb199d7cff52d93c9ad2a Signed-off-by: Kun Yi <kunyi@google.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
index 169b54772..a9955fe13 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
@@ -41,7 +41,7 @@ python do_merge_sensor_config () {
cmd.append(os.path.join(sensoryamldir, 'config.yaml'))
fetch = os.listdir(sensoryamldir)
- override_urls = filter(lambda f: f.endswith('-config.yaml'), fetch)
+ override_urls = [url for url in fetch if url.endswith('-config.yaml')]
for url in override_urls:
bb.debug(2, 'Merging extra configurations: ' + url)
filename = os.path.join(sensoryamldir, url)
OpenPOWER on IntegriCloud