summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-28 13:00:52 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-02-02 13:44:28 +0000
commit2f63e8c040e2b7149585697d24d2bd6dc37f651a (patch)
tree824fe3ce8b4b9f7f5e9ae0b045f5f5d03665f732 /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
parent0a544b5f874e81a1c4579d3de113c176668b6c80 (diff)
downloadtalos-openbmc-2f63e8c040e2b7149585697d24d2bd6dc37f651a.tar.gz
talos-openbmc-2f63e8c040e2b7149585697d24d2bd6dc37f651a.zip
ipmi: Remove virtual/phosphor-ipmi-fru-config
Replace this virtual with two others: -virtual/phosphor-ipmi-fru-hostfw-config -virtual/phosphor-ipmi-fru-inventory. Update ipmi-fru-parser machine recipes to provide virtual/phosphor-ipmi-fru-inventory rather than virtual/phosphor-ipmi-fru-config. Remove machine recipes on machines that use MRW since a single MRW recipe provides for any MRW using system automatically. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com? Change-Id: Ia0d94b938eb2c7bfadd5a018ae5ea136f14dd874
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
index e0fcb0f20..d6f8c8f1a 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
@@ -5,12 +5,17 @@ PR = "r1"
inherit autotools pkgconfig
inherit obmc-phosphor-systemd
inherit obmc-phosphor-ipmiprovider-symlink
+inherit phosphor-ipmi-fru
+inherit pythonnative
require ${PN}.inc
DEPENDS += " \
- virtual/phosphor-ipmi-fru-config \
+ virtual/phosphor-ipmi-fru-hostfw-config\
+ virtual/phosphor-ipmi-fru-inventory \
systemd \
+ python-mako-native \
+ python-pyyaml-native \
phosphor-ipmi-host \
phosphor-mapper \
autoconf-archive-native \
@@ -27,3 +32,12 @@ HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+# TODO: Fix the the ipmi-fru-parser code generator to handle split
+# host firmware / inventory YAML and replace the OECONF below with:
+#
+# EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml"
+# EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml"
+#
+# For now the generator requires them to already be combined so we have:
+EXTRA_OECONF = "YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml"
OpenPOWER on IntegriCloud