summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-28 11:53:03 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-02-02 13:43:07 +0000
commit3acb95c97521320122bdd1c735226a597c1b4363 (patch)
tree38cbbeb8183695a6e3b8ef269785d81576ab4258 /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
parent961df760805a18770a897998a2617f24766d0a47 (diff)
downloadtalos-openbmc-3acb95c97521320122bdd1c735226a597c1b4363.tar.gz
talos-openbmc-3acb95c97521320122bdd1c735226a597c1b4363.zip
ipmi: Add virtual/phosphor-ipmi-fru-hostfw-config
This virtual provides a configuration file that describes host firmware implementation details to ipmi-fru-parser. Add a recipe that provides the sample that comes with ipmi-fru-parser. Add a recipe for Hostboot on OpenPower systems. Set the default provider to the example. Set the default on OpenPOWER systems to the hostboot recipe. Change-Id: Iff56c5c0c2ea8aec7ecaa5a5d981da6f88a894f2 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
new file mode 100644
index 000000000..aca1d0aab
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Sample hostfw inventory map for phosphor-ipmi-fru"
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+require phosphor-ipmi-fru.inc
+
+PROVIDES += "virtual/phosphor-ipmi-fru-hostfw-config"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ DEST=${D}${hostfw_datadir}
+ install -d ${DEST}
+
+ # TODO: copy example hostfw yaml to ${DEST}/config.yaml
+ # install fru-types.yaml ${DEST}/config.yaml
+}
OpenPOWER on IntegriCloud