summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/inventory
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-28 15:28:17 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-02-13 19:24:47 +0000
commitb7d3a495084ac96513a32ed2b44009732be5d285 (patch)
tree63a564628363a1c1120aa4e18738d3d27e13f72e /meta-phosphor/common/recipes-phosphor/inventory
parent29fd2159a12449065ae19b141670123431e03f2e (diff)
downloadtalos-openbmc-b7d3a495084ac96513a32ed2b44009732be5d285.tar.gz
talos-openbmc-b7d3a495084ac96513a32ed2b44009732be5d285.zip
Add inventory manager class
Change-Id: Ib034680499f16efb842bc5074e269bb590f25fbd
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/inventory')
-rw-r--r--meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb5
-rw-r--r--meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb3
2 files changed, 5 insertions, 3 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
index 880d5ac9b..e59bc881a 100644
--- a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
@@ -2,6 +2,7 @@ SUMMARY = "Managed inventory with Phosphor inventory manager - example"
PR = "r1"
inherit native
+inherit phosphor-inventory-manager
require phosphor-inventory-manager.inc
@@ -9,9 +10,9 @@ S = "${WORKDIR}/git"
do_install() {
SRC=${S}/example
- DEST=${D}${datadir}/phosphor-inventory-manager
+ DEST=${D}${base_datadir}
for f in `find $SRC -type f -printf "%P\n"`; do
- install -D ${SRC}/$f $DEST/$f
+ install -D ${SRC}/$f ${DEST}/$f
done
}
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb
index fda1d53cb..3d1dacf19 100644
--- a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb
@@ -7,6 +7,7 @@ PR = "r1"
inherit autotools \
pkgconfig \
pythonnative \
+ phosphor-inventory-manager \
obmc-phosphor-dbus-service
require phosphor-inventory-manager.inc
@@ -27,7 +28,7 @@ DBUS_SERVICE_${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
S = "${WORKDIR}/git"
EXTRA_OECONF = " \
- YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
+ YAML_PATH=${STAGING_DIR_NATIVE}${base_datadir} \
BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
IFACE=${OBMC_INVENTORY_MGR_IFACE} \
OpenPOWER on IntegriCloud