summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-12 22:12:01 -0500
committerAndrew Geissler <geissonator@yahoo.com>2017-01-23 15:52:39 +0000
commitce718f99cf93e2455e2e69f89bea52dda64419c1 (patch)
treea834a3b2e097a0d8bea7af073d74b01297fa4719 /meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
parent9f77d288612846e090ec863a8763a982b67e4d4a (diff)
downloadtalos-openbmc-ce718f99cf93e2455e2e69f89bea52dda64419c1.tar.gz
talos-openbmc-ce718f99cf93e2455e2e69f89bea52dda64419c1.zip
Add recipes for Phosphor inventory manager
Phosphor Inventory Manager is an inventory object lifecycle management application suitable for a wide variety of OpenBMC platforms. Add recipes. Add systemd unit. Change-Id: I4cbaa34b3b787c2ced96efebf36b9b964ddbe8ae Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
new file mode 100644
index 000000000..880d5ac9b
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Managed inventory with Phosphor inventory manager - example"
+PR = "r1"
+
+inherit native
+
+require phosphor-inventory-manager.inc
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ SRC=${S}/example
+ DEST=${D}${datadir}/phosphor-inventory-manager
+
+ for f in `find $SRC -type f -printf "%P\n"`; do
+ install -D ${SRC}/$f $DEST/$f
+ done
+}
OpenPOWER on IntegriCloud