summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/host
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2017-05-08 15:58:01 -0500
committerAndrew Geissler <andrewg@us.ibm.com>2017-05-09 17:37:14 -0500
commitb1afecc2797d06e1e54094b72c5f2586be73bbdd (patch)
tree85f0703dbbb53144206deff4bc420f6aa2e89c34 /meta-phosphor/common/recipes-phosphor/host
parent293354516d1a6b508ccd403c94a82ad89adf9b66 (diff)
downloadtalos-openbmc-b1afecc2797d06e1e54094b72c5f2586be73bbdd.tar.gz
talos-openbmc-b1afecc2797d06e1e54094b72c5f2586be73bbdd.zip
Add phosphor-host-check and required host services
This application and services will be used by the host reset service to determine if the host is running after a BMC has been rebooted Change-Id: I8299546b0f275ebbb46aa775ab7b0633cc3fd5e0 Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/host')
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb21
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-check@.service20
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service14
3 files changed, 0 insertions, 55 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
index 8533c8eab..e4c54bea9 100644
--- a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
@@ -14,8 +14,6 @@ FMT = "org.openbmc.control.Host@{0}.service"
DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
SYSTEMD_SERVICE_${PN} = " \
op-start-host@.service \
- op-reset-host-check@.service \
- op-reset-host-running@.service \
"
START_TMPL = "op-start-host@.service"
@@ -23,23 +21,4 @@ START_TGTFMT = "obmc-host-start@{1}.target"
START_INSTFMT = "obmc-start-host@{0}.service"
START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
-RESET_CHECK_TMPL = "op-reset-host-check@.service"
-RESET_CHECK_TGTFMT = "obmc-host-reset@{1}.target"
-RESET_CHECK_INSTFMT = "op-reset-host-check@{0}.service"
-RESET_CHECK_FMT = "../${RESET_CHECK_TMPL}:${RESET_CHECK_TGTFMT}.requires/${RESET_CHECK_INSTFMT}"
-
-RESET_RUNNING_TMPL = "op-reset-host-running@.service"
-RESET_RUNNING_TGTFMT = "obmc-host-reset@{1}.target"
-RESET_RUNNING_INSTFMT = "op-reset-host-running@{0}.service"
-RESET_RUNNING_FMT = "../${RESET_RUNNING_TMPL}:${RESET_RUNNING_TGTFMT}.requires/${RESET_RUNNING_INSTFMT}"
-
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'RESET_CHECK_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_HOST_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'RESET_RUNNING_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_HOST_INSTANCES')}"
-
-# Force the standby target to run the host reset check target
-RESET_TMPL_CTRL = "obmc-host-reset@.target"
-SYSD_TGT = "${SYSTEMD_DEFAULT_TARGET}"
-RESET_INSTFMT_CTRL = "obmc-host-reset@{0}.target"
-RESET_FMT_CTRL = "../${RESET_TMPL_CTRL}:${SYSD_TGT}.wants/${RESET_INSTFMT_CTRL}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'RESET_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-check@.service b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-check@.service
deleted file mode 100644
index 7c9a05c8f..000000000
--- a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-check@.service
+++ /dev/null
@@ -1,20 +0,0 @@
-[Unit]
-Description=Check Host%i status on BMC reset
-# TODO: openbmc/openbmc#1274
-#Wants=mapper-wait@-xyz-openbmc_project-control-host%i.service
-#After=mapper-wait@-xyz-openbmc_project-control-host%i.service
-Wants=obmc-host-reset-running@%i.target
-Before=obmc-host-reset-running@%i.target
-Wants=op-reset-chassis-on@%i.service
-After=op-reset-chassis-on@%i.service
-Conflicts=obmc-host-shutdown@%i.target
-ConditionPathExists=/run/openbmc/chassis@%i-on
-
-[Service]
-RemainAfterExit=yes
-Type=oneshot
-ExecStart=/bin/sh -c "echo TODO - Check Host Status on BMC Reset"
-
-
-[Install]
-WantedBy=obmc-host-reset@%i.target
diff --git a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service
deleted file mode 100644
index 9a6ffe60b..000000000
--- a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Start host%i running after BMC reset
-After=obmc-host-reset-running@%i.target
-Requires=obmc-host-reset-running@%i.target
-ConditionPathExists=/run/openbmc/host@%i-on
-
-[Service]
-RemainAfterExit=no
-# TODO: openbmc/openbmc#1205 - target name refactor
-ExecStart=/bin/systemctl start obmc-host-start@%i.target
-
-
-[Install]
-WantedBy=obmc-host-reset@%i.target
OpenPOWER on IntegriCloud