summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/flash
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-09-06 12:22:28 -0400
committerPatrick Williams <patrick@stwcx.xyz>2016-09-12 18:45:18 +0000
commitdbb9856f262618b8039890b5f7f9a95e68e6c312 (patch)
treeda708793f8104e01bf1b98ad12cc582240754dae /meta-phosphor/common/recipes-phosphor/flash
parent194b590eb913cc8463c2c7774865d6bc8b07aa17 (diff)
downloadtalos-openbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.tar.gz
talos-openbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.zip
Drop obmc-phosphor- prefix from recipe collections
Given that these are already in the recipes-phosphor directory this seemed redundant. Change-Id: I48a1ab79e0eda88fc5e6af88f198ca3941e829b8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/flash')
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.py29
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.service9
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb12
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-init.service11
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/org.openbmc.control.Flash.service13
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc.bb19
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc/org.openbmc.control.BmcFlash.service16
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download.bb16
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download/org.openbmc.managers.Download.service12
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb11
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-phosphor-flashd.bb9
11 files changed, 157 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.py b/meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.py
new file mode 100644
index 000000000..5e5dd8f36
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+
+# Contributors Listed Below - COPYRIGHT 2015
+# [+] International Business Machines Corp.
+#
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied. See the License for the specific language governing
+# permissions and limitations under the License.
+
+import time
+import sys
+import dbus
+import dbus.service
+import dbus.mainloop.glib
+
+if __name__ == '__main__':
+ print "obmc-phosphor-flashd starting..."
+
+ while 1:
+ time.sleep(5)
diff --git a/meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.service b/meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.service
new file mode 100644
index 000000000..1b1b892cb
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/files/obmc-phosphor-flashd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Phosphor OpenBMC flash management daemon
+
+[Service]
+Restart=always
+ExecStart=/usr/sbin/obmc-phosphor-flashd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
new file mode 100644
index 000000000..c425027bf
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
@@ -0,0 +1,12 @@
+SUMMARY = "OpenBMC org.openbmc.Flash example implementation"
+DESCRIPTION = "A sample implementation for the org.openbmc.Flash DBUS API. \
+org.openbmc.Flash provides APIs for functions like BIOS flash access control \
+and updating."
+PR = "r1"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+
+SKELETON_DIR = "flashbios"
+DBUS_SERVICE_${PN} += "org.openbmc.control.Flash.service"
+SYSTEMD_SERVICE_${PN} += "obmc-flash-init.service"
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-init.service b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-init.service
new file mode 100644
index 000000000..4893cd1cc
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-init.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Initialize BIOS Flash
+Wants=mapper-wait@-org-openbmc-control-flash-bios.service
+After=mapper-wait@-org-openbmc-control-flash-bios.service
+
+[Service]
+Restart=no
+ExecStart={sbindir}/mapper call /org/openbmc/control/flash/bios org.openbmc.Flash init
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/org.openbmc.control.Flash.service b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/org.openbmc.control.Flash.service
new file mode 100644
index 000000000..fefd172f5
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/org.openbmc.control.Flash.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Phosphor BIOS Code Update
+Wants=mapper-wait@-org-openbmc-managers-Download.service
+After=mapper-wait@-org-openbmc-managers-Download.service
+
+[Service]
+Restart=always
+ExecStart={sbindir}/flash_bios.exe
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc.bb
new file mode 100644
index 000000000..5cf385513
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc.bb
@@ -0,0 +1,19 @@
+SUMMARY = "OpenBMC BMC update utility"
+DESCRIPTION = "OpenBMC BMC update utility."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-compression \
+ python-shell \
+ python-pygobject \
+ python-subprocess \
+ python-io \
+ pyphosphor-dbus \
+ "
+
+SKELETON_DIR = "pyflashbmc"
+DBUS_SERVICE_${PN} += "org.openbmc.control.BmcFlash.service"
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc/org.openbmc.control.BmcFlash.service b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc/org.openbmc.control.BmcFlash.service
new file mode 100644
index 000000000..ddc8ec8ca
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bmc/org.openbmc.control.BmcFlash.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Phosphor BMC Code Update
+Wants=mapper-wait@-org-openbmc-managers-Download.service
+After=mapper-wait@-org-openbmc-managers-Download.service
+Wants=mapper-wait@-org-openbmc-control-bmc0.service
+After=mapper-wait@-org-openbmc-control-bmc0.service
+
+[Service]
+Restart=always
+ExecStart={sbindir}/bmc_update.py
+Environment="PYTHONUNBUFFERED=1"
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download.bb
new file mode 100644
index 000000000..a608b0ab2
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download.bb
@@ -0,0 +1,16 @@
+SUMMARY = "OpenBMC org.openbmc.managers.Download example implementation"
+DESCRIPTION = "An example implementation for the org.openbmc.managers.Download DBUS API."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-pygobject \
+ python-subprocess \
+ pyphosphor-dbus \
+ "
+
+SKELETON_DIR = "pydownloadmgr"
+DBUS_SERVICE_${PN} += "org.openbmc.managers.Download.service"
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download/org.openbmc.managers.Download.service b/meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download/org.openbmc.managers.Download.service
new file mode 100644
index 000000000..e7bd28b7c
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-mgr-download/org.openbmc.managers.Download.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Phosphor Download Manager
+
+[Service]
+Restart=always
+ExecStart={sbindir}/download_manager.py
+Environment="PYTHONUNBUFFERED=1"
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb
new file mode 100644
index 000000000..99085002a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb
@@ -0,0 +1,11 @@
+SUMMARY = "OpenPOWER flashing utility."
+DESCRIPTION = "A BMC/BIOS flashing utility for use on OpenPOWER system."
+PR = "r1"
+
+inherit skeleton-gdbus
+
+# DEPEND,RDEPEND on pflash if the openpower-pflash machine feature is set.
+PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}"
+PACKAGECONFIG[openpower-pflash] = ",,pflash,pflash"
+
+SKELETON_DIR = "op-flasher"
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-phosphor-flashd.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-phosphor-flashd.bb
new file mode 100644
index 000000000..6e4c04a25
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-phosphor-flashd.bb
@@ -0,0 +1,9 @@
+SUMMARY = "Phosphor OpenBMC Flash Management"
+DESCRIPTION = "Phosphor OpenBMC flash management reference implementation."
+PR = "r1"
+
+inherit obmc-phosphor-flash-mgmt
+inherit obmc-phosphor-pydbus-service
+
+S = "${WORKDIR}"
+SRC_URI += "file://${PN}.py"
OpenPOWER on IntegriCloud