summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/fans
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-17 16:24:12 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-05-05 23:26:07 +0000
commitc7b071c9f765d94ef69debfbecb2ff649311dccf (patch)
treec921c9d49003f897cfaeb0c35bf906741f84f0cd /meta-phosphor/common/recipes-phosphor/fans
parentb74ceea5375a932be18583bd4c095bd9ec667826 (diff)
downloadtalos-openbmc-c7b071c9f765d94ef69debfbecb2ff649311dccf.tar.gz
talos-openbmc-c7b071c9f765d94ef69debfbecb2ff649311dccf.zip
Recipes for installing fan zone yaml
Provides the virtual/phosphor-fan-control-zone-config virtual. By default, it will install an empty zones.yaml file into the directory needed by the phosphor-fan-control compile. To provide a system specific fan zone yaml, put one in that system's layer and install it with a .bbappend, which is what is being done in this commit for Witherspoon. Change-Id: Ie58fc9eb7b39cecffa39905266542bae16c0f977 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/fans')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb15
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config/zones.yaml2
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb
new file mode 100644
index 000000000..4d8759e47
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor fan zone definition default data"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-fan
+
+SRC_URI += "file://zones.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${control_datadir}
+ install -D zones.yaml ${DEST}/zones.yaml
+}
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config/zones.yaml b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config/zones.yaml
new file mode 100644
index 000000000..d25803ce6
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-config/zones.yaml
@@ -0,0 +1,2 @@
+#Default fan zone definition YAML - empty.
+#For format, see documentation in fan control code repository example yaml.
OpenPOWER on IntegriCloud