summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/fans
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-05-01 13:13:29 -0500
committerMatt Spinler <spinler@us.ibm.com>2017-05-11 15:16:46 -0500
commit8dff73f48842bc6005f03b84e585ae93cb849f08 (patch)
tree2efe8c84e61a620880b3b19d5daa3c5282a13da2 /meta-phosphor/common/recipes-phosphor/fans
parent56e3527d15a8a52becba600926d3aebe838d1550 (diff)
downloadtalos-openbmc-8dff73f48842bc6005f03b84e585ae93cb849f08.tar.gz
talos-openbmc-8dff73f48842bc6005f03b84e585ae93cb849f08.zip
Install fan monitor yaml
The phosphor-fan-monitor-config-native recipe will install the fan monitor configuration yaml so other recipes can use it. To install a system specific version of the yaml, a .bbappend in that system's layer should be used, otherwise an empty yaml file will be installed. Change-Id: I310704846915320b5644eda1d5b933471436b2f9 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/fans')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb15
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config/monitor.yaml2
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb
new file mode 100644
index 000000000..02420e43e
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor fan monitor definition default data"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-fan
+
+SRC_URI += "file://monitor.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${monitor_datadir}
+ install -D monitor.yaml ${DEST}/monitor.yaml
+}
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config/monitor.yaml b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config/monitor.yaml
new file mode 100644
index 000000000..ce60a2202
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-monitor-config/monitor.yaml
@@ -0,0 +1,2 @@
+#Default fan monitor definition YAML - empty.
+#For format, see documentation in fan monitor code repository example yaml.
OpenPOWER on IntegriCloud