summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/fans
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2017-10-24 14:04:46 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-11-10 16:41:07 +0000
commitb5e69d65ee153205fec0419f2345a8063e77dde3 (patch)
treeb6bad06d57830a50049c2ceed560d140fe739431 /meta-phosphor/common/recipes-phosphor/fans
parentbdeca3eb3cea455e9d899b241bab19c93efb5e44 (diff)
downloadtalos-openbmc-b5e69d65ee153205fec0419f2345a8063e77dde3.tar.gz
talos-openbmc-b5e69d65ee153205fec0419f2345a8063e77dde3.zip
Update fan init services
Change the fan monitor and control init services to be wanted instead of required for the power on target. This allows the system to continue to power on if these were to fail. Change-Id: Ic3caf31f6fb1b8b4462f49e2733af3d6d8f686ad Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/fans')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb4
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-control-init@.service2
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-monitor-init@.service2
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
index 79329b0df..42368f74c 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
@@ -80,7 +80,7 @@ FMT_CONTROL = "../${TMPL_CONTROL}:${FAN_CONTROL_TGT}.requires/${INSTFMT_CONTROL}
TMPL_CONTROL_INIT = "phosphor-fan-control-init@.service"
INSTFMT_CONTROL_INIT = "phosphor-fan-control-init@{0}.service"
-FMT_CONTROL_INIT = "../${TMPL_CONTROL_INIT}:${POWERON_TGT}.requires/${INSTFMT_CONTROL_INIT}"
+FMT_CONTROL_INIT = "../${TMPL_CONTROL_INIT}:${POWERON_TGT}.wants/${INSTFMT_CONTROL_INIT}"
FILES_${PN}-control = "${sbindir}/phosphor-fan-control"
SYSTEMD_SERVICE_${PN}-control += "${TMPL_CONTROL} ${TMPL_CONTROL_INIT}"
@@ -105,7 +105,7 @@ FMT_MONITOR = "../${TMPL_MONITOR}:${FAN_CONTROL_TGT}.requires/${INSTFMT_MONITOR}
TMPL_MONITOR_INIT = "phosphor-fan-monitor-init@.service"
INSTFMT_MONITOR_INIT = "phosphor-fan-monitor-init@{0}.service"
-FMT_MONITOR_INIT = "../${TMPL_MONITOR_INIT}:${POWERON_TGT}.requires/${INSTFMT_MONITOR_INIT}"
+FMT_MONITOR_INIT = "../${TMPL_MONITOR_INIT}:${POWERON_TGT}.wants/${INSTFMT_MONITOR_INIT}"
FILES_${PN}-monitor = "${sbindir}/phosphor-fan-monitor"
SYSTEMD_SERVICE_${PN}-monitor += "${TMPL_MONITOR} ${TMPL_MONITOR_INIT}"
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-control-init@.service b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-control-init@.service
index d4dc28035..b78457f6c 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-control-init@.service
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-control-init@.service
@@ -10,4 +10,4 @@ ExecStart=/usr/bin/env phosphor-fan-control --init
SyslogIdentifier=phosphor-fan-control
[Install]
-RequiredBy=obmc-chassis-poweron@%i.target
+WantedBy=obmc-chassis-poweron@%i.target
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-monitor-init@.service b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-monitor-init@.service
index a01acad4c..a5cfd8515 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-monitor-init@.service
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan/phosphor-fan-monitor-init@.service
@@ -10,4 +10,4 @@ ExecStart=/usr/bin/env phosphor-fan-monitor --init
SyslogIdentifier=phosphor-fan-monitor
[Install]
-RequiredBy=obmc-chassis-poweron@%i.target
+WantedBy=obmc-chassis-poweron@%i.target
OpenPOWER on IntegriCloud