summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/events
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2016-09-29 15:52:24 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-10-05 21:16:17 +0000
commit6d8095259198737bf919c898cbea7318f843cadb (patch)
treed41d007623dc06f194758e1a5f5518eb5df460af /meta-phosphor/common/recipes-phosphor/events
parent02da4558476f294c56790ddabb7763d6ff245bdf (diff)
downloadtalos-openbmc-6d8095259198737bf919c898cbea7318f843cadb.tar.gz
talos-openbmc-6d8095259198737bf919c898cbea7318f843cadb.zip
phosphor-event: Convert build process to autotools
Change-Id: I7bb9a72623bcc8231493a802cf95777e01014acb Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/events')
-rw-r--r--meta-phosphor/common/recipes-phosphor/events/obmc-phosphor-event.bb19
1 files changed, 5 insertions, 14 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/events/obmc-phosphor-event.bb b/meta-phosphor/common/recipes-phosphor/events/obmc-phosphor-event.bb
index 43825f427..1d412d791 100644
--- a/meta-phosphor/common/recipes-phosphor/events/obmc-phosphor-event.bb
+++ b/meta-phosphor/common/recipes-phosphor/events/obmc-phosphor-event.bb
@@ -3,32 +3,23 @@ DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
HOMEPAGE = "https://github.com/openbmc/phosphor-event"
PR = "r1"
-
+inherit autotools pkgconfig
inherit obmc-phosphor-license
inherit obmc-phosphor-dbus-service
-inherit obmc-phosphor-c-daemon
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
PROVIDES += "virtual/obmc-event-mgmt"
RPROVIDES_${PN} += "virtual-obmc-event-mgmt"
-TARGET_CXXFLAGS += " -std=c++11 -fpic"
-TARGET_CFLAGS += " -fpic"
-
SRC_URI += "git://github.com/openbmc/phosphor-event"
-
-SRCREV = "059b35e1eabdd87ad02b4343692789386c134082"
-
-RDEPENDS_${PN} += "libsystemd"
-DEPENDS += "systemd"
+SRCREV = "acdc2a909e7464111b259fb94509dcf8dab7c626"
DBUS_SERVICE_${PN} = "org.openbmc.records.events.service"
SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/eventd/eventd.conf"
S = "${WORKDIR}/git"
-INSTALL_NAME = "event_messaged"
-do_install() {
+do_install_append() {
install -d ${D}/var/lib/obmc/events/
- install -m 0755 -d ${D}${sbindir}
- install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/phosphor-eventd
}
OpenPOWER on IntegriCloud