summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/dump
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2017-07-05 10:31:16 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-07-07 19:35:53 +0000
commit416458c07e0e8f7f5172f79f63d540a2d5083f1f (patch)
tree90946a4b545c6037f7507fb18cc58848d89443d8 /meta-phosphor/common/recipes-phosphor/dump
parentbb4499fc3e2f972b734d2a0fa0a8cd61d7b8e76e (diff)
downloadtalos-openbmc-416458c07e0e8f7f5172f79f63d540a2d5083f1f.tar.gz
talos-openbmc-416458c07e0e8f7f5172f79f63d540a2d5083f1f.zip
Enforce Dump directory creation prior to Dump manager starts
Create Dump file storage location before Dump Manager application starts. Change-Id: I583b8cdb853ac1ac18e50c05404f90a2fbb6d5e1 Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/dump')
-rw-r--r--meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb10
-rw-r--r--meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/xyz.openbmc_project.Dump.Manager.service1
2 files changed, 9 insertions, 2 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
index 56e80ee7d..0f935296d 100644
--- a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
@@ -22,7 +22,8 @@ SYSTEMD_PACKAGES = "${PN}-monitor"
inherit autotools \
pkgconfig \
obmc-phosphor-dbus-service \
- pythonnative
+ pythonnative \
+ phosphor-debug-collector
require phosphor-debug-collector.inc
@@ -46,10 +47,15 @@ RDEPENDS_${PN}-monitor += " \
phosphor-logging \
"
+MGR_SVC ?= "xyz.openbmc_project.Dump.Manager.service"
+
+SYSTEMD_SUBSTITUTIONS += "BMC_DUMP_PATH:${bmc_dump_path}:${MGR_SVC}"
+
FILES_${PN}-manager += "${sbindir}/phosphor-dump-manager"
FILES_${PN}-monitor += "${sbindir}/phosphor-dump-monitor"
-DBUS_SERVICE_${PN}-manager += "xyz.openbmc_project.Dump.Manager.service"
+DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
+
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/xyz.openbmc_project.Dump.Manager.service b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/xyz.openbmc_project.Dump.Manager.service
index 9aeba9322..84f8232c3 100644
--- a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/xyz.openbmc_project.Dump.Manager.service
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/xyz.openbmc_project.Dump.Manager.service
@@ -2,6 +2,7 @@
Description=Phosphor Dump Manager
[Service]
+ExecStartPre=/bin/sh -c 'mkdir -p {BMC_DUMP_PATH}'
ExecStart={sbindir}/phosphor-dump-manager
Restart=always
Type=dbus
OpenPOWER on IntegriCloud