summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-10-05 20:10:23 -0400
committerPatrick Williams <patrick@stwcx.xyz>2016-10-12 03:14:42 +0000
commit12e3d60ffc692e6e79c4129a9daad45955bea54b (patch)
treebf93b6dda8a2386cc93552c6e1e19946ab00b62c /meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
parent60cfb39a1ed41dc3764d2f23fa8cba200da719ce (diff)
downloadtalos-openbmc-12e3d60ffc692e6e79c4129a9daad45955bea54b.tar.gz
talos-openbmc-12e3d60ffc692e6e79c4129a9daad45955bea54b.zip
Rename obmc-mapper -> phosphor-mapper
To meet naming conventions. Change-Id: I7ce975dca7c5371ff3fa503a75bbaadd8457d05b Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb b/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
new file mode 100644
index 000000000..ab4589ba3
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Phosphor DBUS Object Manager"
+DESCRIPTION = "Phosphor DBUS object manager."
+HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit obmc-phosphor-dbus-service
+inherit obmc-phosphor-systemd
+inherit setuptools
+
+DEPENDS += "systemd"
+
+DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper.service"
+SYSTEMD_SERVICE_${PN} = "mapper-wait@.service"
+RDEPENDS_${PN} += " \
+ python-xml \
+ python-dbus \
+ python-pygobject \
+ "
+SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
+
+SRCREV = "a562704d9b9c3f77deb1b957d0f586f7f5b9ca3e"
+
+S = "${WORKDIR}/git"
+
+do_compile_append() {
+ oe_runmake -C libmapper
+}
+
+do_install_append() {
+ oe_runmake -C libmapper install DESTDIR=${D}
+}
+
+python populate_packages_prepend () {
+ mapperlibdir = d.getVar("libdir", True)
+ do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
+}
+PACKAGES_DYNAMIC += "^libmapper.*"
+FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"
OpenPOWER on IntegriCloud