summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2016-10-05 16:20:54 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-11-11 14:53:12 +0000
commit11381c45b0bb3c7856d28f708610dfaa2353a2e7 (patch)
tree7cf70d25728fc8edfafb1df74750443bef8166bc /meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
parent9e376b889a756ed0760dfb4ae402e9b7c2f2d7ab (diff)
downloadtalos-openbmc-11381c45b0bb3c7856d28f708610dfaa2353a2e7.tar.gz
talos-openbmc-11381c45b0bb3c7856d28f708610dfaa2353a2e7.zip
phosphor-objmgr:Convert build process to autotools
Resolves openbmc/openbmc#380 Change-Id: I63c15e56c3d58959e567a561fa890e1806a14177 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb b/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
index 9a598dabf..8ffc41b1c 100644
--- a/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
+++ b/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper.bb
@@ -5,14 +5,17 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+inherit pythonnative
+inherit autotools pkgconfig
inherit obmc-phosphor-dbus-service
inherit obmc-phosphor-systemd
-inherit setuptools
DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper.service"
SYSTEMD_SERVICE_${PN} = "mapper-wait@.service"
+RDEPENDS_libmapper += "libsystemd"
RDEPENDS_${PN} += " \
python-xml \
python-dbus \
@@ -20,17 +23,14 @@ RDEPENDS_${PN} += " \
"
SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
-SRCREV = "36eb1e52265f2c765d0f0c56914841a1e2f54fe5"
+SRCREV = "7122244c83092499dc8d7836da0a63a08c734856"
S = "${WORKDIR}/git"
-do_compile_append() {
- oe_runmake -C libmapper
-}
-
-do_install_append() {
- oe_runmake -C libmapper install DESTDIR=${D}
-}
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
python populate_packages_prepend () {
mapperlibdir = d.getVar("libdir", True)
@@ -38,3 +38,4 @@ python populate_packages_prepend () {
}
PACKAGES_DYNAMIC += "^libmapper.*"
FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
OpenPOWER on IntegriCloud