summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-07-09 23:41:49 -0400
committerPatrick Williams <patrick@stwcx.xyz>2017-07-18 01:05:16 +0000
commit2ad7ce334819f2f2d1e8bd06b160126b41591d07 (patch)
treebda977018f73bbbf78a87668bef46f4807ab0a5a /meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
parent0ead07ae105a71b1ab7140bf2ecbdcfb0e66f2c6 (diff)
downloadtalos-openbmc-2ad7ce334819f2f2d1e8bd06b160126b41591d07.tar.gz
talos-openbmc-2ad7ce334819f2f2d1e8bd06b160126b41591d07.zip
mapper: Generate an environment file
Mapper will soon consume four command line arguments that limit the scope of watched path and interface namespaces. Add tooling to generate this environment file based on a new bitbake variables. Add xyz-openbmc_project and org-openbmc by default in the Phosphor layer and other layers can add additional namespaces as needed. Change-Id: I1c03aa91b75d03652a8a8fb80737553fef224fdf Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper-config-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper-config-native.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper-config-native.bb b/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
new file mode 100644
index 000000000..976c59b9c
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Phosphor Mapper Configuration"
+DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
+configuration files to the native /usr/share/phosphor-mapper filesystem."
+HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit native
+inherit phosphor-mapper
+
+PHOSPHOR_MAPPER_CONFIGS = " \
+ phosphor-dbus-interfaces-mapper-config-native \
+ phosphor-legacy-namespace-mapper-config-native \
+ "
+
+DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
+
+# To add namespaces and blacklists to the mapper configuration,
+# create a native recipe in your layer, and add it to
+# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
+# Recipes should set one of the variables below.
+# Consult phosphor-mapper.bbclass for additional information.
+
+# Add path namespaces to be monitored.
+PHOSPHOR_MAPPER_NAMESPACE = ""
+
+# Add interfaces to be monitored.
+PHOSPHOR_MAPPER_INTERFACE = ""
+
+# Blacklist paths from being monitored.
+PHOSPHOR_MAPPER_NAMESPACE_BLACKLIST = ""
+
+# Blacklist interfaces from being monitored.
+PHOSPHOR_MAPPER_INTERFACE_BLACKLIST = ""
+
+do_install() {
+ install -d ${D}/${namespace_dir}
+ install -d ${D}/${interface_dir}
+ install -d ${D}/${blacklist_dir}
+ install -d ${D}/${interfaceblacklist_dir}
+}
OpenPOWER on IntegriCloud