summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/chassis
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2018-03-27 13:56:26 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-04-06 00:44:50 +0000
commit5c76e0cf9f742cae4156c30c033af50be1135ab7 (patch)
treeb69cfbba5ec42153f48164c902945bc2328c4ad2 /meta-phosphor/common/recipes-phosphor/chassis
parentd1ce2b877602202f89f3f55864e83e7ca2764194 (diff)
downloadtalos-openbmc-5c76e0cf9f742cae4156c30c033af50be1135ab7.tar.gz
talos-openbmc-5c76e0cf9f742cae4156c30c033af50be1135ab7.zip
Introduce new host-startmin action target
Requirements have arisen for OpenBMC firmware to run certain services only during fresh power on operations. To achieve that, break the obmc-host-start action target into two targets. The existing obmc-host-start target will now call the new obmc-host-startmin target. The startmin target will be the minimum services required to start the host. The obmc-host-start target is where services that should only be called during a fresh power on can be placed. The initial use case for this is the obmc-host-reboot target. It will call this new obmc-host-startmin target to do the bare minimum on a reboot operation. This then allows the use case for OpenBMC to only reset the host reboot count on a fresh power on operation. A new service will be added to the obmc-host-start target to do this. If a reboot operation is issued, or a host watchdog is triggered to cause a reboot, this service would not be started, ensuring the reboot count is properly decremented. Tested: Verified on/off/reboot and ran CT regression suite. https://gerrit.openbmc-project.xyz/#/c/9821/ is required for reboots to work properly. Change-Id: I86df03e6d671178c1525f852e196c4102bb73cb6 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/chassis')
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect/pcie-slot-detect@.service2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb
index e341463b5..fabddf37e 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb
@@ -68,7 +68,7 @@ SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'RESET_ON_CHASSIS_FMT', 'OBMC_POWE
# Now show that the main control target requires these power targets
START_TMPL_CTRL = "obmc-chassis-poweron@.target"
-START_TGTFMT_CTRL = "obmc-host-start@{1}.target"
+START_TGTFMT_CTRL = "obmc-host-startmin@{1}.target"
START_INSTFMT_CTRL = "obmc-chassis-poweron@{0}.target"
START_FMT_CTRL = "../${START_TMPL_CTRL}:${START_TGTFMT_CTRL}.requires/${START_INSTFMT_CTRL}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT_CTRL', 'OBMC_POWER_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb
index 6b5761b5e..6e0ad9719 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb
@@ -9,7 +9,7 @@ inherit pkgconfig
SKELETON_DIR = "pciedetect"
TMPL = "pcie-slot-detect@.service"
-TGTFMT = "obmc-host-start@{0}.target"
+TGTFMT = "obmc-host-startmin@{0}.target"
INSTFMT = "pcie-slot-detect@{0}.service"
FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect/pcie-slot-detect@.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect/pcie-slot-detect@.service
index 91adb769b..4545524d3 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect/pcie-slot-detect@.service
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect/pcie-slot-detect@.service
@@ -11,4 +11,4 @@ ExecStart=/usr/bin/env pcie_slot_present.exe
SyslogIdentifier=pcie_slot_present.exe
[Install]
-WantedBy=obmc-host-start@%i.target
+WantedBy=obmc-host-startmin@%i.target
OpenPOWER on IntegriCloud