summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power
diff options
context:
space:
mode:
authorJosh D. King <jdking@us.ibm.com>2017-04-06 15:56:37 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-04-20 15:43:45 +0000
commitefb04a1963ee03f7db756cb33ae52f024ffda086 (patch)
treed7dc1bf3dddc378580651944e965b256240fe15b /meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power
parentb9ee536d0aae31718054ddad187a93d761d9dea2 (diff)
downloadtalos-openbmc-efb04a1963ee03f7db756cb33ae52f024ffda086.tar.gz
talos-openbmc-efb04a1963ee03f7db756cb33ae52f024ffda086.zip
Refactor action target names Host-start-stop
The target change is: obmc-chassis-stop -> obmc-host-stop obmc-chassis-start -> obmc-host-start Removed CHASSIS_FMT and CHASSIS_LINK_FMT because they are no longer needed. CHASSIS_POWER_FMT_2 did not change because its used for obmc-chassis-reset. Deleted files obmc-chassis-start@.target and obmc-chassis-stop@.target because they are no longer needed. I moved over their contents to obmc-host-start and obmc-host-stop. Updated phosphor-state-manager.bb and skeleton-rev.bbclass to have correct commit id. Change-Id: I26cba4153038f39d60e8d450a05969a216848abe Signed-off-by: Josh D. King <jdking@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power')
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-start@.service2
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-stop@.service2
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-off@.service2
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-on@.service2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-start@.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-start@.service
index f76695e7b..befc89296 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-start@.service
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-start@.service
@@ -15,4 +15,4 @@ Type=oneshot
ExecStart={sbindir}/mapper call /org/openbmc/control/power%i org.openbmc.control.Power setPowerState i 1
[Install]
-WantedBy=obmc-chassis-start@%i.target
+WantedBy=obmc-host-start@%i.target
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-stop@.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-stop@.service
index 86ddf4a32..dd3570e01 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-stop@.service
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-power-stop@.service
@@ -12,4 +12,4 @@ RemainAfterExit=yes
ExecStart={sbindir}/mapper call /org/openbmc/control/power%i org.openbmc.control.Power setPowerState i 0
[Install]
-WantedBy=obmc-chassis-stop@%i.target
+WantedBy=obmc-host-stop@%i.target
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-off@.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-off@.service
index 32ae6942d..a5efb4133 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-off@.service
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-off@.service
@@ -14,4 +14,4 @@ ExecStart={sbindir}/pgood_wait /org/openbmc/control/power%i off
ExecStart=/bin/rm -f /run/openbmc/chassis@%i-on
[Install]
-WantedBy=obmc-chassis-stop@%i.target
+WantedBy=obmc-host-stop@%i.target
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-on@.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-on@.service
index 1c85fc1b9..cd4f513a0 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-on@.service
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power/op-wait-power-on@.service
@@ -15,4 +15,4 @@ ExecStart={sbindir}/pgood_wait /org/openbmc/control/power%i on
TimeoutSec=30
[Install]
-WantedBy=obmc-chassis-start@%i.target
+WantedBy=obmc-host-start@%i.target
OpenPOWER on IntegriCloud