summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-kernel
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-03 23:53:25 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-10 12:06:22 -0400
commit981707d977a903edcdeb543850ef01947adf2f07 (patch)
tree39a971482e8cf78d2ac7bc7b762645cf24342222 /meta-phosphor/common/recipes-kernel
parent1051b3a3c013d84c5b25c600e1745cd0770274b9 (diff)
downloadtalos-openbmc-981707d977a903edcdeb543850ef01947adf2f07.tar.gz
talos-openbmc-981707d977a903edcdeb543850ef01947adf2f07.zip
AST2400: Set kernel preferred provider version
In preparation for supporting AST2500 with a different branch. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-kernel')
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc.inc27
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb27
2 files changed, 28 insertions, 26 deletions
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc.inc b/meta-phosphor/common/recipes-kernel/linux/linux-obmc.inc
new file mode 100644
index 000000000..24db6f784
--- /dev/null
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "Linux kernel for OpenBMC"
+SECTION = "kernel"
+LICENSE = "GPLv2"
+
+KCONFIG_MODE="--alldefconfig"
+
+KSRC ?= "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
+SRC_URI = "${KSRC}"
+
+LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
+
+do_patch_append() {
+ for DTB in "${KERNEL_DEVICETREE}"; do
+ DT=`basename ${DTB} .dtb`
+ if [ -r "${WORKDIR}/${DT}.dts" ]; then
+ cp ${WORKDIR}/${DT}.dts \
+ ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
+ fi
+ done
+}
+
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
index 825a555dd..ef854a58f 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
@@ -1,30 +1,5 @@
-DESCRIPTION = "Linux kernel for OpenBMC"
-SECTION = "kernel"
-LICENSE = "GPLv2"
-
KBRANCH ?= "dev-4.4"
-KCONFIG_MODE="--alldefconfig"
-
-SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
-
LINUX_VERSION ?= "4.4"
-LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
-
SRCREV="openbmc-20160606-1"
-PV = "${LINUX_VERSION}+git${SRCPV}"
-
-COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
-
-inherit kernel
-require recipes-kernel/linux/linux-yocto.inc
-
-do_patch_append() {
- for DTB in "${KERNEL_DEVICETREE}"; do
- DT=`basename ${DTB} .dtb`
- if [ -r "${WORKDIR}/${DT}.dts" ]; then
- cp ${WORKDIR}/${DT}.dts \
- ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
- fi
- done
-}
+require linux-obmc.inc
OpenPOWER on IntegriCloud