summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-11-04 12:33:27 -0400
committerPatrick Williams <patrick@stwcx.xyz>2016-11-08 18:59:17 +0000
commitf03fee3d24ea7fade8ca2178b381745f167c9235 (patch)
tree62892e850c7aa4703913b263f82fc531a297ba25 /meta-phosphor/common/recipes-devtools
parent068b41c3ddcccbb5bc9898b194d38cea9ecffa8b (diff)
downloadtalos-openbmc-f03fee3d24ea7fade8ca2178b381745f167c9235.tar.gz
talos-openbmc-f03fee3d24ea7fade8ca2178b381745f167c9235.zip
Add recipe for python-inflection
Change-Id: If5849e79bd341c5eecccbfb12c5b042d2f122c44 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-devtools')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-inflection.inc20
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb5
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-inflection.inc b/meta-phosphor/common/recipes-devtools/python/python-inflection.inc
new file mode 100644
index 000000000..819b3682f
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-inflection.inc
@@ -0,0 +1,20 @@
+SUMMARY = "A port of Ruby on Rails inflector to Python"
+DESCRIPTION = "Inflection is a string transformation library. It singularizes \
+and pluralizes English words, and transforms strings from CamelCase to \
+underscored string. Inflection is a port of Ruby on Rails’ inflector to Python."
+HOMEPAGE = "http://github.com/jpvanhal/inflection"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=de7833d9c2ce0052a4073928c76a13d7"
+
+inherit allarch
+inherit setuptools
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-re \
+ ${PYTHON_PN}-codecs \
+ "
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb b/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
new file mode 100644
index 000000000..ce19f99a4
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
@@ -0,0 +1,5 @@
+SRCNAME = "inflection"
+SRC_URI = "https://pypi.python.org/packages/source/i/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=tarball"
+SRC_URI[tarball.sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca"
+SRC_URI[tarball.md5sum] = "7941165e9f148e0520023941c0886b40"
+require python-inflection.inc
OpenPOWER on IntegriCloud