summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-devtools
diff options
context:
space:
mode:
authorJosh King <jdking@us.ibm.com>2016-10-31 11:09:24 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-12-05 20:31:00 +0000
commit39312ed6989037e2c676b043efb93b217f9d2b34 (patch)
tree2b5db95af254f3117651c8a43feca83d7f9feea1 /meta-phosphor/common/recipes-devtools
parent43d8242f0c2cbce87a3277d90f4bbff0ce537880 (diff)
downloadtalos-openbmc-39312ed6989037e2c676b043efb93b217f9d2b34.tar.gz
talos-openbmc-39312ed6989037e2c676b043efb93b217f9d2b34.zip
Fixed journal flooding of SSL messages
The problem was that when a curl command was given without any options, several error messages would be thrown that can flood the journal. To fix this I had to use a 'try catch' statment to catch the error. I modified the current 'try catch' statement to catch and pass on the ssl error so no error messages of that kind could flood the journal. After implementation no more ssl error messages were flooding the journal, however a new error was thrown so I had to create an additional exception and pass on it as well. This fixes issue number 583. Resolves openbmc/openbmc#583 Change-Id: I4857861f3c0ff103e2bccf9f5a5821c8219aefe6 Signed-off-by: Josh King <jdking@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-devtools')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch13
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend2
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch b/meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch
new file mode 100644
index 000000000..36990e851
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch
@@ -0,0 +1,13 @@
+--- a/gevent/ssl.py 2016-11-02 13:17:37.917401795 -0500
++++ b/gevent/newssl.py 2016-11-02 13:17:23.085401962 -0500
+@@ -334,6 +334,8 @@ class SSLSocket(socket):
+ raise
+ sys.exc_clear()
+ self._wait(self._write_event, timeout_exc=_SSLErrorHandshakeTimeout)
++ elif ex.reason in ['SSLV3_ALERT_CERTIFICATE_EXPIRED', 'TLSV1_ALERT_UNKNOWN_CA']:
++ return None
+ else:
+ raise
+
+ def connect(self, addr):
+ """Connects to remote ADDR, and then wraps the connection in
diff --git a/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend b/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend
index 00a7c0d4a..4dd9786de 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend
+++ b/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend
@@ -1,4 +1,4 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://libev-config-guess.patch"
SRC_URI += "file://0001-gevent-py279-ssl-wrap.patch"
-
+SRC_URI += "file://0002-gevent-eat-ssl-self-cert-errors.patch"
OpenPOWER on IntegriCloud